Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't access my Tomato router remotely (normally I could login through SSH), but I can access the computers on my home network, so it's operating and I can go through it to them. But they can't access it, either:

~> ssh 192.168.1.1
ssh_exchange_identification: Connection closed by remote host

~> lynx 192.168.1.1
Looking up  '192.168.1.1' first

Looking up 192.168.1.1 first
Looking up 192.168.1.1
Making HTTP connection to 192.168.1.1
Sending HTTP request.
HTTP request sent; waiting for response.
Retrying as HTTP0 request.
Looking up 192.168.1.1
Making HTTP connection to 192.168.1.1
Sending HTTP request.
HTTP request sent; waiting for response.
Alert!: Unexpected network read error; connection aborted.
Can't Access `http://192.168.1.1/'
Alert!: Unable to access document.

Is there some other way I can reboot it or crash it or otherwise trigger it to reboot remotely?

share|improve this question

2 Answers 2

I you can access the connected LAN machines, you could try accessing its web interface (just noticed you've already tried that), or access it through telnet, through one of them, to reset it.

These interfaces are only available to local machines by default, for obvious security reasons.

share|improve this answer
    
Yeah but telnet wasn't enabled. :/ I unplugged it when I got home, and it came back up and is working fine. I guess I can configure it to self-reboot every few hours or something. –  endolith Sep 16 '10 at 23:28

No, if you can't log in to do a remote reset, you can not reset it. You may try to remember you password, or maybe you changed the HTTP port or something.

Once there was a power outage in the office I work at and the hole Tomato reset itself to factory defaults, so you may need to physically access the router or at least ask someone to plug it out and in again.

share|improve this answer
    
It's not a lost password issue. Something glitched and it stopped responding to SSH. The DSL modem is automatically unplugged on a timer twice a day, but the router isn't. :) Maybe that will fix something, or maybe it will disconnect me for good. –  endolith Sep 16 '10 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.