Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm experiencing three strange problems on OS X (Snow Leopard), which only appear while I am connected to a wireless network over Airport.

  1. The "Security" tab in System Preferences takes about 1 minute to load, and clicking the lock to make changes also results in a long delay. (Eventually, however, everything works.)
  2. I can't start Mathematica 7. The menu bar appears, but no window appears, and clicking on the menu bar results in the beach ball of death.
  3. I can't save certain files in Adobe Illustrator CS 4. (The application hangs, with 0% CPU usage.)

I've tried some of the "usual" fixes, e.g. repairing permissions, and deleting plist's related to Airport. I'd really like to understand what's going on, however!

I suspect that this is in some way related to the firewall, because the Security tab in System Preferences controls the firewall, and often when I used to successfully start Mathematica 7, I would get the standard firewall dialog, asking if I wanted to allow or deny access to the application. I'm not sure what's changed recently, however.

Can anyone diagnose this issue?

Unfortunately I can't try any alternate network connections; there's only one wireless network around here, and I'm on a Macbook Air and don't have the USB dongle to connect to Ethernet.

UPDATE: actually, Mathematica does start: after approximately 5 minutes the usual firewall dialog appears, and after clicking allow there's another, shorter, delay, and then a window opens.

share|improve this question
    
Does the problem go away if you turn off the personal firewall? Also, what do the various logs (system.log, kernel.log, firewall logs) say when this slowness is going on? –  Spiff Sep 16 '10 at 18:29
    
No, turning off the firewall doesn't help. I haven't seen anything in the logs yet, but I haven't carefully watched them as I reproduce the problems. I'll report back if I do... –  Scott Morrison Sep 16 '10 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.