Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I start command prompt (cmd.exe) in my Vista Business 32-bit, it acts as if the Insert key was toggled, so whatever I type overwrites the characters under the cursor. I can turn it off by pressing Insert, but whenever I move into a new line (next command), Insert turns back on.

It's incredibly annoying and unfortunately I don't know how this happened, but I'd like to turn this mode off.

share|improve this question
Happens in Windows 7 as well. I miss Linux. This and many other crap just doesn't happen in Linux. –  AlikElzin-kilaka Jul 11 at 7:43

1 Answer 1

up vote 15 down vote accepted

At the extreme top left of most windows, there is a small box which - when clicked - opens the system menu. Usually this menu contains nothing much more than Move, Size, Minimize and Maximize. For command windows, it also includes Properties. Select that, go to the Options tab and make sure that Insert mode is enabled. Click OK to save your changes, and when prompted, choose "Save properties for future windows with same title".

You can also do this by right-clicking on the shortcut you use to open the command window and selecting Properties.

share|improve this answer
ah, thanks. I had Insert mode disabled, but it's apparent that Insert Mode does exactly the opposite of what I thought. –  Axarydax Sep 17 '10 at 15:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.