Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have many fonts installed and VLC's font cache rebuilding takes several minutes.

What is it for? How can I disable it?

share|improve this question
    
Does it hang at 20%? Does it complete? Does it happen every time? –  Tom Wijsman Feb 23 '11 at 11:01
    
@Tom It finished in a little under three minutes to build a 4.68 MB cache file out of 1,582 fonts. Just restarting VLC isn't enough to trigger a cache rebuild; installing a font is. The percentage is no longer shown. –  badp Feb 23 '11 at 11:08
add comment

4 Answers

Found this after some digging in the VLC forums. (image by me)

Building font cache pop-up

Solution:

  1. Open VLC player.
  2. On menu bar: Tools/Preferences
  3. (At bottom - left side) Show settings -- ALL
  4. Open: Video Click: Subtitles/OSD (this is now highlighted, not opened).
  5. Text rendering module - change this to "Dummy font renderer function"
  6. Save Exit
  7. Re-open - done. Progy will no longer look outside self for fonts.

alt text


DISCLAIMER:

You must set your VLC PLayer preferences to "All"

share|improve this answer
1  
Still no joy. –  badp Sep 17 '10 at 15:19
    
As seen in the link of @harrymc's solution, the portable version makes it worse. –  Tom Wijsman Feb 23 '11 at 10:56
1  
I don't think this answer covers the current version of VLC player. The user interface for preferences was reworked some time ago. Or it may depend on the platform. –  Peter Mortensen Aug 21 '11 at 18:08
1  
People, this worked. I just tested using 1.11. Has nobody figured that the "reworked interface" can be just switched back by clicking the "All" button on the bottom left corner? –  kizzx2 Oct 2 '11 at 17:06
add comment

I think you are left with two options:

  1. Recompile the program configured with --disable-fontconfig, or modify the source code.

  2. Trim down your fonts folder, I don't think you really need all 1500+ there all the time.

    You are probably using less than 33% of them, start by killing the fonts that take the most size...

share|improve this answer
add comment

I suppose you are on Windows 7?

From disable font cache? :

Right click on the vlc.exe and select Properties.
Click the Compatibility tab and check the box for "Run this program in compatibility mode for", then select "Vista Service Pack 1".

I just did this on Windows 7 and not only does the font cache loading thing not come up, but VLC opens instantly instead of having that couple of seconds delay.

If this doesn't work, I would suggest to totally uninstall VLC using Revo Uninstaller Freeware, ensure that the installation folder was really deleted, then reinstall. I must remark that I have tried VLC under a Win7 VM, and it had an immediate startup time.

EDIT

The discussion at Rebuilding Font Cache problem in new VLC seems to indicate that this is a problem of the latest VLC version, and that reverting to version 1.0.5 fixes it.

I want to clarify that this is not actually an error, but is a feature by design (see the portable apps link above). Every time you install a font, you can expect this to happen. To prevent this from happening in newer versions of VLC, you would actually need to recompile the software/find a recompiled version of the software (again, see link).

share|improve this answer
    
No cigar. –  badp Feb 23 '11 at 10:53
    
See my edit above. –  harrymc Feb 23 '11 at 11:18
    
An advanced uninstall, followed by reinstall, had me greeted by the font cache rebuild window. –  badp Feb 23 '11 at 11:50
    
Added one more edit. –  harrymc Feb 23 '11 at 12:08
    
Why down-vote solutions that worked for some people for exactly the same problem? –  harrymc Feb 25 '11 at 14:41
add comment

I guess you mean "Front Cache". I got the same message since version 1.1.0. I found a solution where you need to delete the cache file in the directory %appdata%/vlc/. That worked for me. The name of the file is something cryptic. Mine was something like d031bbba323fd9e5b47e0ee5a0353f11-i686.cache-3

If the problem returns you also can delete the vlc-cache-gen.exe in the Programm Files/VLC folder. VLC will never again generate the cache. I found this suggestion at the same source like the other one above. But I don´t know if that will cause some other problems because I didn´t try deleting the vlc-cache-gen.exe.

Source of solution (german forum): Chip.de - VLC Media player

share|improve this answer
1  
Nope: I meant font cache. Deleting the font cache causes it to be rebuilt, obviously. I'll try and rename the font cache generating executable then... once it's done generating the font cache obviously >.< –  badp Sep 17 '10 at 10:18
    
Renaming the executable did not fix the issue. Process Explorer shows it's VLC itself doing the caching. –  badp Sep 17 '10 at 10:39
add comment

protected by Diago Nov 17 '10 at 16:41

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.