Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are times I need to edit root protected files, so I have to keep entering the root password again and again. I've already set up the rule so terminal is gonna ask me for root password only once per hour. Confirmed that is working. But I still have to enter the same password for textmate. Is there a way to get this resolved?

I understand the risk, but keep entering the same password is also too annoying.

share|improve this question
    
As an aside: any details on the rule so terminal is gonna ask me for root password only once per hour? –  Arjan Sep 19 '10 at 15:37
    
Did you try sudo mate filename? –  romainl May 7 '11 at 19:20

2 Answers 2

There is a utility called cocoasudo which is similar to gksudo for Linux.

share|improve this answer

You could try making TextMate owned by root and set the setuid flag on it. Package these changes up as a toggling shell script if you don't want to leave it on indefinitely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.