Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I changed my desktop environment from GNOME to KDE yesterday, and after that I'm unable to connect to any wireless networks. I can find wireless networks, but for some reason unable to connect to them.

How can I rectify this ?

share|improve this question
    
I changed to title to make it more search friendly, hope you don't mind. – tj111 Sep 17 '10 at 15:57
    
can you post your solution as an answer and edit this post so that it reflects a question ? – Sathya Sep 17 '10 at 15:58
    
@Sathya I marked it as community wiki, because I figured that approach was dishonest. :/ – Andy Sep 17 '10 at 16:07
1  
you can form your own question and answer :) Just post the solution as an answer, I'll edit the question – Sathya Sep 17 '10 at 16:14
    
@Sathya okay,I posted my answer. :) – Andy Sep 17 '10 at 21:02

Well, I found a solution.

Most guides on the subject suggested removing Network-Manager and installing WICD, but I didn't have ANY internet, so this wasn't an option. Here's how I fixed it:

First, I edited /etc/NetworkManager/nm-system-setting.conf file so that it contained Managed=True

Next, I ensured that ath5k module was not blacklisted in /etc/modprobe.d/. To do this, just run

grep -r "ath5k" /etc/modprobe.d/

and confirm that nothing is returned.

I followed this up with

killall nm-applet
nm-applet --sm-disable

and rebooted my system. When it came back up, I actually WAS connected wirelessly again, but the nm-applet was still missing from my notification panel. However, now that I had internet, I was able to install wicd

sudo apt-get install -d wicd

And to ensure that I could connect through wicd instead of NetworkManager, and I uninstalled Network-Manager via

sudo apt-get remove network-manager

I hope this helps anyone else out in my situation, because were I not bald already I would have pulled my hair out last night.

share|improve this answer
    
Thanks for your answer Andrew, I hope it helps someone ! – Sathya Sep 17 '10 at 22:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .