Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've mastered how to disable/delay the Automatic Restart prompt after Windows Update deems it necessary to restart my computer in XP.

But, now I'm using both Windows 7 and Vista and that method no longer works. So far, I have not been able to circumvent the Restart Reminder popup that keeps telling me Restart or Postpone decision for 10 min/1 hour/4 hours (and then popping up again after that delay). Does anyone know how to delay that popup for something like a day (24 hours) or disable it completely?

share|improve this question
I hate this popup too! – Colonel Panic Jul 22 '13 at 18:28

6 Answers 6

up vote 0 down vote accepted

Maybe this is the solution

Download page here

Some more solutions in this thread

share|improve this answer
This disables/stops the Windows Update service which works but also might have side-effects. The other answer is a clean and permanent solution. – usr Nov 25 at 13:53

An easier way than messing around with the registry, or having to run a command after every update:

Open the Local Group Policy Editor:

Start / Run / gpedit.msc

Find the Windows Update settings:

Computer Configuration / Administrative Templates / Windows Components / Windows Update

Edit these 2 settings:

No auto-restart with logged on users for scheduled automatic updates installations: Enabled

Re-prompt for restart with scheduled installations: Enabled, wait period (minutes): 1440

Now you will not be prompted to restart for 24 hours.

share|improve this answer
Works in XP, but not Windows 7. – palswim May 21 '13 at 18:52
It works for me in Windows 7 – nickspoon Jul 9 '13 at 23:59
Home editions of Windows don't have the group policy editor. – Colonel Panic Jul 22 '13 at 18:27
Enable it:… – reflexiv May 3 '14 at 7:05
Didn't work for me in Windows 7 SP1 Enterprise in a domain situation. – Sam Oct 15 '14 at 2:20

You can manually edit the registry using regedit. The best explanation I've found is from the How To Geek here: The link contains automatic ways I'm posting the manual method here:

Open up regedit.exe through the start menu search box or run dialog, and navigate down to the following key, creating new keys if they don’t exist.


enter image description here

Create a new 32-bit DWORD value named NoAutoRebootWithLoggedOnUsers and give it a value of 1 to prevent automatic reboot while users are logged on. Delete the value to put things back to the way they were.

share|improve this answer
This prevents automatic restart but doesn't stop the nagging notification that takes you out of games and full screen video every 4 hours. – Muhd Mar 31 '12 at 8:10

Try this command

sc stop wuauserv

see if it stops the nag.

You would need to do this every time you do an update that requires a reboot.

Alternatively, you can go to Start Menu>Run>regedit, on the side click HKEY_LOCAL_MACHINE>SOFTWARE>Microsoft>Windows>CurrentVersion>Run. Once in that folder, right click on the right side of the screen and select New>String Value. Name it "Disable Windows Update Restart Notification" and in the path type in "Cmd.exe sc stop wuauserv" (without the quotes, as those indicate a path).

Other suggestions here, this article is for Vista, but maybe some of the reg hacks will work for 7

share|improve this answer
That's true; I have seen that command. But, I was looking for a more permanent solution. Sadly, I've tried the settings in the article, but even with the settings, the popup persists at least once every four hours. – palswim Sep 20 '10 at 15:38

Save this in a .reg file. Run it

Windows Registry Editor Version 5.00

share|improve this answer

One (and perhaps the easiest way) is to just kill the Windows Update process.

1) Click start menu

2) Type 'cmd' to the "Search programs and files" and run it by pressing Enter.

3) Change into admin mode by pressing Ctrl+Shift+Enter. (or just run the exe with right click -> Run as administrator)

4) Type net stop “windows update”

You can observe that the Windows Update icon disappears from the taskbar, and you will get a text "The Windows Update service was stopped succesfully"). This should work in both Windows 7 and Vista.

Note: The solution is temporary. The Windows Update process will come back after you have restarted your computer.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.