Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell inspiron 640m (1405). I am a reasonably clued in linux user, but I am getting serious networking speed problems.

The networking card is an intel 3945ABG

When wirelessly connecting with windows XP, everything runs fine and the network connection is fast.

When connecting with any linux distro, the networking speed is abysmally slow, and the connection drops randomly. (the network is recognised and the connection is made however)

Is there any possible reason why that would be?

Help me get the penguin back on my laptop!

[EDIT]: Using latest firmware for the card. The module used is iwl3945. unloading/reloading module doesn't change the behaviour. The networking speed is still ridiculously slow. There are no errors in dmesg. Using ArchLinux and module autoloading (tried manual unload/reload too...) .

[RESOLVED]: By using ndiswrapper. The iwl3945 driver seemed to be the cause of the problem. Downloading the windows driver from dell and using the .INF files works as expected:

  • Blacklist iwl3945
  • Install the driver: ndiswrapper -i /path/to/***.INF
  • Check that the driver is loaded: ndiswrapper -l
  • Load the ndiswrapper module.
share|improve this question

2 Answers 2

Please try these steps:

  • Check the output of dmesg and look for error signs::

    dmesg | grep -i error
    
  • Try reloading the kernel modules related with your card.

    • Hopefully lsmod | grep iwl may show you what you need to unload.

    • I usually need to reload iwlagn and iwlcore.

    • Use modprobe -r [module-name] to remove and modprobe [module-name]

    • If you do not have these iwl drivers, you need an update.

  • Try ifconfig wlan0 and see if you have errors.

share|improve this answer
    
Hey Can, No error in dmesg. Tried reloading all modules to no avail. (its iwl3945 for my card) Am using the latest firmware (on Archlinux) which I manually downloaded from XP. Didn't make any difference. Will add info to the main post. Thanks anyway. –  brice Sep 18 '10 at 16:10
1  
Using ndiswrapper where there is a open source version available... I I am sharing you pain :) –  Can Burak Cilingir Sep 19 '10 at 15:42
up vote 2 down vote accepted

Use Ndiswrapper.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.