Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This should be easy but I just cannot seem to get it working despite searching for answers, so I turn to you fine ladies and gentlemen. This is what my C:\Documents and Settings\user_vimperatorrc file looks like:

set "editor=C:\\bin\\gvim.exe -f"

The gvim executable does exist there and it runs. When in the text area I type C-i and I get this error:

Command not found: C:bingvim.exe

I have tried a bunch of other things but none have worked. Can someone share with me how you got it working in windows?

share|improve this question
    
Have you tried triple or quadruple backslashes (or even single ones)? – Dennis Williamson Sep 18 '10 at 2:30
1  
Your quotation mark placement is weird. Have you tried either set editor="C:\\bin\\gvim.exe -f" or set editor='C:\bin\gvim.exe -f'? I don't use Windows, but just using set editor in my .vimperatorrc didn't work for me. I had to do what I described in this topic: superuser.com/questions/186782/… – frabjous Sep 18 '10 at 3:05
    
I will try these suggestions when I get back to that computer. In the mean time if anyone has a real working example I would appreciate that as well. – stephenmm Sep 18 '10 at 19:51
    
set editor='C:\\bin\\gvim.exe -f' finally worked. – stephenmm Sep 20 '10 at 15:18
    
@stephenmm, Can you put that as an answer and mark it as accepted so that this question doesn't show up as unresolved? Thanks. – dsolimano Jan 19 '12 at 20:14

This is what finally worked for me in Windows 7 after trying TONS of different escaping possibilities. Turns out you need / for the path separator, and \\ before a space:

set editor="C:/Program\\ Files\\ (x86)/Vim/vim73/gvim.exe"
share|improve this answer
1  
but of course... facepalm – Ярослав Рахматуллин Nov 21 '13 at 21:29
up vote 1 down vote accepted

This was the solution I came up with:

set editor='C:\\bin\\gvim.exe -f'
share|improve this answer
    
For reference, in pentadactyl I'm using set editor='C:\\Program\ Files\ (x86)\\Vim\\vim73\\gvim.exe -f +<line> +"sil! call cursor(0, <column>)" <file>' – raylu Mar 12 '12 at 9:00

I just came across this issue. On the Windows XP SP3 machine that I am forced to deal with, I added this line:

set editor='C:\\Program\ Files\\Vim\\vim73\\gvim.exe -f'

To this file:

C:\Documents and Settings\dotancohen\_vimperatorrc
share|improve this answer

On a Windows 7 machine, I added the directory containing the gvim.exe executable (C:\Program Files (x86)\Vim\vim74 in my case) to the PATH environmental variable, so typing gvim in a DOS box worked.

I then restarted Firefox, and all worked as expected.

share|improve this answer

Win8 required

:set editor="C:/Program\\ Files/vim/vim74/gvim.exe\ -f"
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .