Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In php file :

<?php
...
?>
<html>

</html>

I could not indent the html source code with operator =.

How could I indent it?

share|improve this question
up vote 4 down vote accepted

My workaround for this is to temporarily switch to html mode, mark region and indent, and then go back to php mode.

:set filetype=html
" mark html code
=
:set filetype=php
share|improve this answer

There is an entry on the Vim Tips Wiki that details how to enable indenting of both PHP and HTML areas of PHP files: http://vim.wikia.com/wiki/Better_indent_support_for_php_with_html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.