Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a fresh install of Ubuntu Server 10.04.1 on VMWare Player 3.1.1, the keyboard mappings are crazy!

The arrows don't work, Ctrl key seems mapped to Enter, it's nuts!

Note, this is a command-line server only, without X-Windows.

The host is Windows 7.

What's the quick and easy fix??

Thanks

share|improve this question
    
Crazy question: During install did you select the default US keyboard layout? –  KronoS Sep 18 '10 at 17:08
    
I used the automated "easy install" through the VMWare prompts. Was never prompted for a keyboard type. –  Alex R Sep 18 '10 at 18:45
    
Install Ubuntu properly. Download the ISO and install it in a fresh virtual machine. –  Hello71 Mar 23 '11 at 22:21
    
Anyone found an answer to this? Having the same problem. nthrbldyblg.blogspot.com/2008/06/… Blog suggested all sorts of things, but none of them worked for me! :( –  user81232 May 14 '11 at 12:24

2 Answers 2

up vote 1 down vote accepted

Try

dpkg-reconfigure console-setup

Should work in console.

Use A key to jump to the ACPI standard (since arrow keys are not working), and then TAB, Enter to proceed with the setup. You can leave all other settings on their defaults.

In the end reboot the machine.

share|improve this answer

Change the layout in preferences. Using xmodmap isn't Ubuntu way.

share|improve this answer
    
What preferences? vi /etc/preferences? or what :-) ? –  Alex R Sep 18 '10 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.