Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a 3G modem whilst o2 tranfer over adsl. trouble is no websites load but I can resolve domains. I enabled masquerade on the PPP0 ( modem) interface. added the server as default route for all workstations.

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

net.ipv4.ip_forward = 1″ to /etc/sysctl.conf

why?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Can you get to the remote system's tcp port 80?

#any of these would work.
telnet www.google.com 80
echo > /dev/tcp/www.google.com/80
nc www.google.com 80

What does your iptables filter table look like?

iptables -L

Have you tried purging your iptables filter?

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -F INPUT
iptables -F OUTPUT
share|improve this answer
    
I only have one rule thats listed when I execute iptables -L and thats's ACCEPT all -- anywhere anywhere. It's to allow connection from the rest of my lan into the server. My server has no monitor so I'm using ssh. When I was downloading using wget it couldn't connect. I also can't ping external ip's. But it works fine on the server. –  ageis23 Sep 19 '10 at 9:20
    
I'm using my adsl router to issue ip's to the workstations, does this matter? It does have nat disabled so it should be a standard router. At least that's what the manual said. The chains are flushed automatically within the startup scripts. I'm also found some errors in the /var/log/messages file. My kernel doesn't support ppp filtering and pppd can't determine remote ip. –  ageis23 Sep 19 '10 at 17:14
    
Then you might want to set some routs and see if those will work. –  Kevin M Sep 20 '10 at 14:11
    
yeah sorry I gathered that. It wasn't clear on the tutorial. I was using ipmasq but by default it blocked everything and so I couldn't connect to my server. I removed all the rules to isolate which rules are blocking ssh. Also for some reason the ip forward wasn't sticking as well despite I added it sysconfig. –  ageis23 Sep 20 '10 at 17:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.