Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accidentally imported a large number of folders and emails into my outlook exchange account. It will let me delete the mail messages, but any folder that has message in it cannot be deleted. This means I have to go through each folder and empty it out first, which will be painfully long.

Is there any way around this problem? Perhaps just a way to force empty the trash?

Error looks something like this:

Outlook has not finished synchronizing local changes made to items in this folder. You can not delete this folder until the synchronization with the server is complete.

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

Try going out of cached mode and then emptying the folders.

To enable or disable Cached Exchange Mode: Outlook 2010 and 2007

  1. In 2010, from the File tab, under "Account Information", click Account Settings, and then choose Account Settings... .

    In 2007, from the Tools menu, select Account Settings... .

  2. Highlight your Exchange server account, and then click Change... .

  3. To turn Cached Exchange Mode on or off, under "Microsoft Exchange Server:", check or uncheck Cached Exchange Mode. Click Next, and in the window that opens, click OK.

  4. Click Finish. Restart Outlook for the change to take effect.

Outlook 2003

  1. From the Tools menu, select Email Accounts... .

  2. In the window that opens, under "Email", make sure View or change existing email accounts is selected, and then click Next.

  3. Highlight your Exchange server account, and click Change... .

  4. To turn Cached Exchange Mode on or off, under "Microsoft Exchange Server:", check or uncheck Cached Exchange Mode. Click Next, and in the window that opens, click OK.

  5. Click Finish. Restart Outlook for the change to take effect.

share|improve this answer
    
In hind sight, this would also work. If you don't have anything that has changed, deleting the OST file is fine as well. Cheers! –  Stephano Oct 29 '10 at 18:48
add comment

I googled the error and people were talking about deleting an OST file. That seemed to fix things.

share|improve this answer
add comment

Disabling cached mode did not do it for me.

What did work was to "blow away" the outlook profile by going to Control Panel/Mail, click the Show Profiles button and then click the Remove button to delete the default profile named "Outlook". Then, click the Add button, name the new profile with a different name (I append the word outlook with a 2) and let the user restart Outlook and go through the new user wizard again. Once the profile had reloaded from the server, problem solved!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.