Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with windows search service. Although it is enabled in "Control panel/Programs/Turn Windows features on or off", it is disabled in services.msc. Because of that search in windows explorer and start menu don't work. Is there any way to run this service?

alt text

P.S. I've just installed some third-party software, this may be the reason.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I can't speak for the third party software, it is possible that it has disabled the service - you may want to uninstall it or find out the reasons in case they conflict with each other.

However, to enable a disabled service, all you do is:

Go in to computer management, (Click the Start Orb > Right click on Computer > Click on Manage)

Next, go down to Services and Applications > Services and look for Windows Search Service

Make sure that this is set to Automatic (Delayed Start).

alt text

Edit based on comments.

I have no idea why the service would not be there if it is installed correctly. At your own risk, you can recreate the service by typing the following at a command prompt:

SC create WSearch binPath= "C:\Windows\system32\SearchIndexer.exe /Embedding" 
share|improve this answer
1  
@Sergey - I have no idea why it wouldn't be there other than third party software - updating answer now –  William Hilsum Sep 19 '10 at 18:34
1  
@Sergey - to undo it, type "SC delete wsearch" clearly something is wrong, the Windows Search application is not installed on your machine. Try unticking in windows components then reinstalling. –  William Hilsum Sep 19 '10 at 18:59
1  
The reason for Wsearch and not the friendly name is because I didn't specify in the command above. –  William Hilsum Sep 19 '10 at 18:59
1  
@Sergey I mean, go to windows components and untick Windows Search, click ok - then go back and tick it and click ok. –  William Hilsum Sep 19 '10 at 19:15
1  
@Sergey - that is because for some reason it isn't installed! see if you can now add it. –  William Hilsum Sep 20 '10 at 13:49

Tried a few other things and finally I gave up and reinstalled Windows. Now I have a habit to create restore points!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.