Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run server 2008 r2 as my desktop OS.

I am trying to disable the annoying restart prompt that comes up after installing updates. The most I can postpone it to is 4 hours.

I have tried disabling “Re-prompt for restart with scheduled installations” and enabling “No auto-restart [...] for scheduled Automatic Update installation” in Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update in gpedit.msc, to no avail.

I have looked at various guides, and nothing seems to work.

I do want automatic updates, and I have it set to notify me immediately, and allow me to choose what to download and install. I just don't want this nagger screen to keep coming up, for various reasons.

Is there a fix?

Please don't respond with a lecture about why I should restart automatically, as your assumptions may not be valid.

share|improve this question
add comment

2 Answers 2

up vote 12 down vote accepted

From Disable Windows Update restart nag:

To stop this service, open Command Prompt (Start>Run>cmd>Enter) and type the following command sc stop wuauserv. This will not prevent Automatic Updates from starting at the next boot. So don't worry, you'll keep getting Windows updates. Just don't forget to restart eventually.

From disable Automatic Update restart prompts using Windows Computer Policy
(was this the one you mentioned in your post?):

Start / Run / gpedit.msc / Local Computer Policy / Computer Configuration / Administrative Templates / Windows Components / Windows Update / and disable Re-prompt for restart with scheduled installations.

You can use a freeware product to Disable Windows Update Restart Alert Message With WindowsUpdateSilencer:

If you want to get rid of Windows Update notification then here is WindowsUpdateSilencer useful tool which runs in the background and will automatically silence all Windows update notifications.

(I have never used this program and can't vouch for it, especially on Server 2008.)

share|improve this answer
    
I'm not interested in stopping the service as a solution, as I am looking for a permanent solution. The group policy solution was indeed the one I tried, and it does not work at all. –  user48869 Sep 19 '10 at 20:11
    
You can push the time limit from 4 hours to 24. See RebootRelaunchTimeout in technet.microsoft.com/en-us/library/cc708449%28WS.10%29.aspx. You can also do it thru the above policy entry (enabled = 1440 minutes). –  harrymc Sep 19 '10 at 20:18
    
Also see my edit above for WindowsUpdateSilencer. –  harrymc Sep 19 '10 at 20:27
    
Thanks Harry, will give them both a try –  user48869 Sep 19 '10 at 20:35
    
Disabling "Re-prompt for restart with scheduled installations" only sets the default 10 minutes re-prompt time. With that policy you can go only so far as to postpone by 24 hours (1440 mins) –  Sergio May 8 '13 at 10:33
add comment

According to here, the correct configuration is to Enable the following option:

No auto-result with logged on users for scheduled automatic update installations
  1. Click Start -> Run

  2. Enter “gpedit.msc”

  3. Go to Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update

  4. Double-click on “No auto-restart for scheduled Automatic Update installation”

  5. Enable it!

  6. Reboot the computer

As its description clearly meets the goal:

Specifies that to complete a scheduled installation, Automatic Updates will wait for the computer to be restarted by any user who is logged on, instead of causing the computer to restart automatically.

If the status is set to Enabled, Automatic Updates will not restart a computer automatically during a scheduled installation if a user is logged in to the computer. Instead, Automatic Updates will notify the user to restart the computer.

Be aware that the computer needs to be restarted for the updates to take effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.