Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Until recently I used Windows Vista on my computer. Now I have installed Windows 7. But when I choose shut-down in Windows, the computer isn't turned-off at 100%. The disks are turned off, but CPU-fan is still on and I can't use the "power-on"-button to start the computer, unless I hold it a few seconds to 100% turn off the computer before.

How to fix this?

share|improve this question
    
Check what the event logs say - anything unusual there? –  DMA57361 Sep 20 '10 at 11:09
    
Are there any warning events? –  harrymc Sep 20 '10 at 17:38
    
If you boot the system using a Linux live CD, say Knoppix or Ubuntu, and shut down, does it shut off correctly? If not, it is likely a hardware problem and its coinciding with the Win7 upgrade is a coincidence. –  CarlF Nov 5 '10 at 20:28
add comment

4 Answers

up vote 1 down vote accepted

If you are using BitLocker, then there is a hotfix for this problem.

See this article:
A computer stops responding during shutdown if BitLocker is enabled on the system drive on a computer that is running Windows 7 or Windows Server 2008 R2

Another possibility from Windows 7 Beta: Shutdown problem

Device Manager, select "IEEE 1394 Bus Host Controllers" group, only contains one device called "VIA 1394 OHCI Compilant Host COntroller" on that click right mouse button and select "Properties", select "Power Management" tab, and finally check the "Allow the computer to turn off this device to save power" box.

In any case, even if you don't have such a device, better test that all possible devices have this power policy turned on.

share|improve this answer
    
I'm not using BitLocker, but I use dynamic disks and mirroring on the system drive, so maybe it's related!? –  Jonas Sep 20 '10 at 12:56
    
Questions: (1) Have you turned on "clear the virtual memory pagefile on shutdown", (2) Does it finally shut down after waiting at least 15 minutes, (3) What is your computer model? –  harrymc Sep 20 '10 at 13:25
    
@harrymc: (1) No, where do I find that setting? (2) No, it's all night. –  Jonas Sep 20 '10 at 13:28
    
Does this problem happen after boot into Safe mode? –  harrymc Sep 20 '10 at 17:39
1  
OK: Have added another possibility. –  harrymc Nov 5 '10 at 19:43
show 1 more comment

Check the system events logs (inside the computer management screen) from around the time when the system fails to shutdown.

Look for any errors or warnings around this time, because there is presumably something that is blocking the system from completely closing down and if there is a relevant log entry it will probably provide a good starting point for troubleshooting.

share|improve this answer
add comment

Are you sure you select shutdown and not standby? I think vista has standby where you would normally have shutdown in xp

share|improve this answer
add comment

It looks like a problem with your HAL driver, or BIOS ACPI Settings. I've encountered this problems on older version of windows, with Standard PC HAL instead of ACPI.

You need to check Device Manager -> -> should be: ACPI x86-based PC or Advanced Configuration and Power Interface (ACPI) PC.

If you have anything else, then this is your problem.

Also, check your BIOS settings - there should be one that says: ACPI Enabled or something similar.

share|improve this answer
    
This only means you are on Windows 7 64-bit. –  harrymc Sep 20 '10 at 17:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.