Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two computers both running Windows 7 Professional x64. One computer has a USB printer connected (Dell V715W) which is working properly. When I create a RDP connection from the PC with the printer to the other PC, the printer is not shared.

In the RDP settings I selected to share the printer in Local Resources, but no printer is visible.

share|improve this question
    
2 items for anyone looking at this old post: Have you installed the driver on the remote machine? Do that first. If it is still not seen: Could you look at the properties of the printer on the system with the printer actually installed? What port is it on? Is it something other than a COM, LPT, or USB? If so, RDP doesn't always like it. You can get around this by enabling printer pooling on that printer and selecting LPT1 as well as the current port for example. –  opsin Jan 18 '12 at 20:58

3 Answers 3

When connecting via RDP click the drop arrow "options" and select the tab Local Resources click the printers check box.

alt text

share|improve this answer
    
I have enabled that, the problem is that the printer is not visible. –  jaapie Sep 20 '10 at 18:45
    
do you have the printer shared over the network? I got confused and though you were talking about the remote PC having the printer –  KronoS Sep 20 '10 at 21:20

I don't fully understand what you mean by "shared".

Say that computer A is with printer. It does RDP to computer B specifying the printer in local resources. Then the printer is available on computer B, but only for this RDP session.

RDP is not a means of sharing resources, just of bringing over your local resources during the session for your own use. And even then you might have problems if computer B doesn't have the right printer driver installed.

For sharing printers over the network, see the following article:
Share a Printer on Your Home Network

Or if you are using HomeGroup see:
Use the Homegroup Feature in Windows 7 to Share Printers and Files

share|improve this answer
    
Yes that is what I mean with sharing, perhaps I picked the wrong word. –  jaapie Sep 20 '10 at 18:45
    
I have added more info. –  harrymc Sep 20 '10 at 18:53

In addition to enabling the Printers option in the RDP setting, you also need to install the printer driver on the computer you are connecting to. Once you do that, you can select the printer for printing.

Alternatively, you can enable a HomeGroup in Windows 7 that will allow you to share printers between any computers connected to your local network. This would eliminate the need to select the Printers option in the RDP settings.

share|improve this answer
    
See proposedsolution.com/solutions/… for some instructions on how to install the printer. –  sgmoore Nov 18 '11 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.