Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First and foremost, I have mmKeys installed correctly. My iTunes works almost perfect while minimized to the tray.

My problem is with the play/pause button on my Wireless Comfort Keyboard 5000. When iTunes does not have focus (like it's minimized, or if it isn't the application I'm active in, like right now while typing this) the play pause button toggles twice.

So, I'll push the pause button - and the song that is playing will pause, but a split second later will start up again. If the song is paused, and I push play, the song will immediately pause again. In order to get the key to work correctly, I must give iTunes focus, and then push the button.

Here's a video I created on youtube:

OS: Windows 7 x64
Intellitype: 8.0

Edit: Apparently I have intellitype 8.0 instead of 7.1

share|improve this question
up vote 2 down vote accepted

It appears the implementation of play/pause may be bugged - or simply changed in iTunes 10 / IntelliType 8.0. I downloaded and installed the following:

It is a series of VBS scripts that are run with iTunes. I make no warrantee or guarantee as to their safety. Firstly, I removed mmKeys.dll, and then edited PlayPause.vbs. For case 0 and 1, instead of running iTunes.PlayPause, it works if I use iTunes.Play and iTunes.Pause respectively. I then mapped this VBS file to my play pause button. And bam! It works!

' Do the appropriate thing
select case CurState
    case 0
        ' Stopped
    case 1
        ' Playing
    case 2
        ' Fast-forwarding
    case 3
        ' Rewinding
end select
share|improve this answer

Try in iTunes Edit/Preferences and check the box that says Enable full keyboard navigation". That let my keyboard control the iTunes player.

share|improve this answer
I just found the reverse with iTunes 11 - unchecking 'Enable full keyboard navigation' allowed my play/pause keys to work with iTunes. – Jared Harley Mar 19 '14 at 19:57

I just encountered the same behavior you had, and I finally solved it by removing mmkeys. I quit iTunes, then deleted mmkeys.dll from "C:\Users\UserName\AppData\Roaming\Apple Computer\iTunes\iTunes Plug-ins"

After I did that, the plain commands available through the intellitype software worked fine.

share|improve this answer

Maybe this would help:

share|improve this answer
As I said, I have mmKeys installed correctly. Nonetheless, I reinstalled it from your link, and it did not work correctly. – EvilChookie Sep 24 '10 at 17:58

Maybe you should try to uninstall all Apple products and re-install them (including QuickTime, Bonjour, Apple application support and iTunes), using Revo Uninstaller Freeware.

Remember to back up your library before doing this, just in case.

share|improve this answer

I have the same keyboard, same OS and same versions of iTunes and intellitype. I vaguely remember a similar problem on an earlier version of iTunes, but I've since uninstalled and re-installed intellitype.

You could try setting the keys back to default - Control Panel, Keyboard, Key Settings, then click the Restore Defaults button. Also make sure there isn't another media program running in the background (e.g. Winamp).

As I type this, the Play/Pause works fine for me (that's no consolation, I know).

As I have the same setup (in terms of Keyboard, Windows, iTunes and intellitype), happy to help with the odd experiment, if you have other software running in the background, to see if we can narrow down the problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .