Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I disable the Windows + U hotkey in Windows XP? Alternatively, how do I stop the utility manager from being active? The two are related. The utilty manager is currently providing a potential security hole and I need to remove it[1]. The system I'm developing uses a custom Gina to log in and start a custom shell. This removes most Windows Key hotkeys but the Win + U still pops up the manager app.

Update:

Things I've tried and don't work:

  1. NoWinKeys registry setting - this only affects explorer hotkeys;
  2. Renaming utilman.exe - program reappears next login;
  3. Third party software - not really an option, these machines are audited by the clients and additional, third party software would be unlikely to be accepted.

Also, the proedure needs to be reasonably straightforward - this has to be done by field service engineers to existing machines (machines currently in Russia, Holland, France, Spain, Ireland and USA).

[1] The hole is via the internet options in the help viewer the utility app links to.

share|improve this question
    
..i encountered this link, this one might help. windowsitpro.com/systems-management/how-can-i-disable-winu –  kryte1988 May 18 '13 at 14:31
add comment

12 Answers

up vote 5 down vote accepted

Utility Manager is located in the WINDOWS\system32 directory. The file is utilman.exe. Just renaming the file to something else will stop it from being launched when Windows + U is pressed.

share|improve this answer
1  
This is indeed the answer, but the procedure to rename the file is tricky as it can reappear if it is running when the renaming happens. It's not ideal but is the only method that works. –  Skizz Aug 24 '09 at 15:43
    
What about removing it from the dllcache as well? Or whatever that folder is with backup copies of programs –  Canadian Luke Nov 28 '11 at 17:36
    
@Skizz I can't test it, but I believe you should have more luck if you boot other OS (e.g. some kind of rescue CD/flashdirve or live CD/flashdirve) and rename the file from there. And if it proves to work well, you can also create a custom Live CD/flashdrive to simplify (or even automate) the task. –  Alois Mahdal Jan 21 '12 at 22:32
    
This doesn't work for me - the utilman is just recreated the next time I press Windows-U –  dsummersl May 15 '12 at 17:05
1  
another option: leave file in place, but deny its execution via filesystem permissions (Deny "Traverse folder / execute file" for everyone). This way, windows file protection won't find anything suspicious. –  LogicDaemon Dec 1 '13 at 6:50
add comment

I've experience similar problems in the past - the best solution I have found is to alter the permissions of the utilman.exe so that no user has the rights to run it:

Right click - properties - security - Deny all.

share|improve this answer
add comment

In Utility Manager properties I went to security tab and disabled access to all users (for administrators as well) and after doing that it does not run.

share|improve this answer
add comment

Under C:\Windows\System32 you can rename utilman.exe to disable it.

This should cause the hotkey to become unresponsive as well. In case you want to take extra precautions for the hotkey you can remap it using AutoHotkey like so:

# & u::return

Win + u should no longer do anything.

share|improve this answer
    
AutoHotkey to the rescue again :) –  Toby Allen Aug 6 '09 at 23:31
    
Adding more software is not an option due to the nature of the system (and introducing more dependancies). This is for a cash counting machine so, as you'd expect, customers are wary of unknown third party software. –  Skizz Aug 7 '09 at 8:50
    
The renaming option may be the only solution. I hoped there'd be something a bit neater. –  Skizz Aug 7 '09 at 8:52
    
Renaming doesn't work, the app magically reappears at next boot up. –  Skizz Aug 7 '09 at 9:10
add comment

Renaming C:\WINDOWS\System32\utilman.exe, even with UtilMan processes stopped from within an XP Home SP3 session, appears not to get rid of this shortcut annoyance.

I've had success in getting the change to stick by accessing the XP hdd via a linux session and renaming the annoying exe that way - - no chance that any Win process can monitor your changes if it's not in charge at the time :-) Whether it's going to be hacked back with any new XP updates remains to be seen, however.
Most current linux distros are super flexible with writing to ntfs.

Don't know whether this will fix a Pro install. Good luck.

share|improve this answer
add comment

You can try and disable the C:\windows\system32\utilman.exe in group policy under:

Computer Configuration\Windows Settings\Security Settings\Software Restriction Policies

Add a path rule to C:\Windows\System32\Utilman.exe and set it to Disallowed.

share|improve this answer
add comment

Go to RUN, and enter regedit.

When registry opens click on edit in top left and choose find....

Enter utilities manager and press Enter on the keyboard. Wait while it searches and then delete all 3 utility entries.

I did this and Win+U does nothing now.

There is no point in deleting utilman in "find" as it is a system protected file and just reappears. Something in Windows system uses it so leave it be.

share|improve this answer
add comment

There is a way to disable all Windows Key hotkeys, from the registry, according to this link. Maybe that will help.

share|improve this answer
    
I gave this a go but it seems this only disables hotkey provided by explorer. These are already disabled because explorer isn't running. Win+U still did its thing. –  Skizz Aug 7 '09 at 8:49
    
Yup, and Win+P is set to the projector even if you use a single-monitor desktop, without a proper way to turn that hotkey off. sigh –  Synetech Jun 4 '12 at 3:06
add comment

A better way would be to remove all utilities instead. I don't remember the exact place in the registry though...

(Also, if I remember correctly, the Help menu is inactive when used from the login screen - or am I wrong?)

share|improve this answer
    
I too tried to find the option to disable the application but couldn't find anything in the registry either. –  Skizz Aug 7 '09 at 8:51
add comment

If renaming the utility doesn't work, try deleting the util & replacing it with a null file, [cmd window]

Del utilman.exe
COPY nul utilman.exe
Attr utilman.exe +R

If that doesn't work, write a short do-nothing program to replace utilman.exe

share|improve this answer
add comment

Install AutoHotkey and new a file named AutoHotkey.ahk whthin My Documents and edit it:

  1. Use ';' to uncomment the sample codes;
  2. Add the codes
#u::
return

where # means the Windows key and #u means Win+u, and the :: following nothing except just a return means to do nothing.

share|improve this answer
    
As I commented to John T's answer, adding more software/applications is not an option. –  Skizz Jan 5 '10 at 9:20
add comment

A) Use NTFS permissons Or B) Use GPEdit Machine Policies to disallow to run utilman.exe

http://support.microsoft.com/kb/301422

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.