Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to change the search engine plugin's name (displayed in the drop down menu when you're switching search engines) but to no avail.

I changed the os:ShortName tag in the search plugin xml file under "..my plugin folder..\searchplugins", but after restarting FF still displays the old name. I'm using FF 3.6.10.

Thanks in advance!

share|improve this question
    
There is a bugzilla on this behavior at bugzilla.mozilla.org/show_bug.cgi?id=653926 – studgeek Dec 3 '11 at 18:31
up vote 3 down vote accepted

I just upgraded to Firefox 4, and when changing os:ShortName didn't work turned to the internet. My search plugin does not have an update mechanism embedded, and yet after multiple browser restarts I still get the old name.

EDIT: Problem solved! It turned out that Firefox somehow caches its search engines. All you need to do is:

  • Move the offending search plugin file somewhere else.
  • Start Firefox for it to take notice of a folder change, prompting it to reinitialise the search plugin cache.
  • Close Firefox.
  • Move the file back where it belongs

And voila, done! All your plugins should now be named exactly as YOU want them to :-)

share|improve this answer

in your Firefox/Profiles//searchplugins/blah.xml change the field os:ShortName and remove UpdateUrl to disable it from getting an updated XML from source.

EDIT: create a new file with the following xml

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/" xmlns:os="http://a9.com/-/specopensearch1.1/>
<os:ShortName>blahblah</os:ShortName>
<os:Description>asdad</os:Description>
<os:InputEncoding>UTF-8</os:InputEncoding>
<os:Url type="text/html" method="GET" template="http://www.imdb.com/find?q={searchTerms}&amp;sourceid=mozilla-search">
</os:Url>         
</SearchPlugin>

I have tested this with Firefox4 :)

share|improve this answer
    
My xml file only has <os:Url type="application/opensearchdescription+xml" method="GET" template="..url to xml.." rel="self" /> that serves as update mechanism, I removed it and changed os:ShortName, still doesn't work :( – Dan7 Sep 21 '10 at 14:12
    
could try the thing after the edit. there isn't enough space here – Rohan Monga Sep 22 '10 at 6:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .