Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When the CD-ROM drive is selected in Windows Explorer, the drive ejects. How do I prevent this from happening?

share|improve this question
    
Wow. Interesting. I never noticed that before. Guess I've never selected the CD device inside explorer! – Brian Knoblauch Sep 21 '10 at 19:48

See this very (exactly?) similar question:

http://superuser.com/questions/56017/how-do-i-disable-dvd-auto-eject-in-windows-7

Apparently by disabling the auto-burn feature, you also disable the auto-eject feature:

http://www.mydigitallife.info/2008/02/20/windows-vista-cddvd-optical-drive-auto-eject-or-open-feature/

some info in other answers came from here: http://social.answers.microsoft.com/Forums/en-US/w7hardware/thread/b357e1cd-9211-40ac-8310-16eaede08c74

share|improve this answer

Here are two ways of getting around the issue:

  1. Always leave a disc inside the drive permanently so that whenever you accidentally click on the drive, it opens the contents of the drive rather than ejecting it.

  2. As a sidenote, you can configure the folder options to respond to a double click and not to a single click. The odds of accidentally double-clicking on a CD/DVD drive are far less compared to a single click. Do this in case you have single click configured for Folder Options.

Here’s how:

a) Go to Start, type Folder Options and press Enter.

b) Select the option Double-click to open an item (single-click to select).

c) Click Apply.

d) Click Ok.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .