Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just started getting this error with emacs on my Macbook Pro:

Ispell and its process have different character maps

I've tried changing my character map to utf-8. No luck. It would be nice if it told me how they were different and what to do about it. Any thoughts?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If the coding of the buffer is not specified, EMACS attempts to determining automatically. This causes a problem if the buffer contains a UTF-8 or Latin1 character and the subprocess is determined to be sending up ASCII.

I have solved the problem by placing this line as the first line of my .tex files:

% -*-mode: LaTeX; coding: us-ascii;-*-                                                             
share|improve this answer
    
My buffer is only us-ascii (I searched for [^[:ascii:]]) but I still get the "Ispell and its process have different character maps" message. How can I find out what character map ispell actually uses on my machine? –  phs Mar 29 at 15:43
1  
Look at the environment of the ispell process. You are probably setting the encoding in the LC_ALL or LANG environment variables. –  vy32 Mar 31 at 1:36
1  
I should add that your buffer only having us-ascii characters doesn't mean that it has us-ascii encoding. It could have LATIN1 encoding or UTF8 encoding, since both are proper supersets of us-ascii. –  vy32 Apr 3 at 18:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.