Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just downloaded the latest JRE on a computer running a clean install of Windows 7. Now I want to do three things:

  1. disable automatic updating
  2. remove the icon from the system tray
  3. reduce the amount of space Java uses for temporary files

I was able to do 2 and 3 by going to the Java Control Panel (systray icon > properties, or Control Panel > Java), unchecking the box/changing the number, and selecting "Apply" and "OK." However, I cannot do 1.

My steps so far: go to the Update tab, deselect "Check for Updates Automatically," click "Never Check" instead of "Check Monthly" and see the "Advanced" button get grayed out. Click "Apply" and "OK" and restart. After the machine reboots, open the Java Control Panel... and "Check for Updates Automatically" is enabled again.

A few years ago I had the same problem with a much earlier version of Java. It eventually resolved itself, I assume because it was fixed in a later release. Am I stuck waiting for a fix again, or is there something I can do?

I don't really see my other software interfering, but for completeness, here's everything else I've installed so far:

  • ThinkVantage Toolbox (I'm using a ThinkPad)
  • Symantec Endpoint Protection
  • Firefox 3.6
  • IE 9 beta
  • VLC player
  • Pidgin
share|improve this question

3 Answers 3

I have a solution for you, although it is a commercially related solution, but you can use PolicyPak to create a GPO that will manage nearly every setting within Java. They have a trial mode and community mode editions to either try it out or use in a limited capacity for free. PolicyPak integrates with Windows Group Policy and allows you to manage and lockdown application configuration settings for third party applications like Java even more effectively than Standard Group Policy locks down the various aspects of Windows. The link to its Java Pak is here http://www.policypak.com/products/manage-java-jre-with-group-policy.html and the link to the free editions is here http://www.policypak.com/support-sharing/policypak-trial-community-edition-fully-licensed-modes.html.

Brad (employee of PolicyPak)

share|improve this answer
2  
Welcome to super user, and its great that you have disclosed your affiliation. There's probably two things I'd like to point out. Firstly, your answer sounds like ad-copy as is, and could do with some improvement - perhaps add a howto on solving the specific issue on the answer itself. Secondly, its worth remembering that disclosure is necessary but not sufficient. In general, while its fine to answer questions on your product in an official capacity, if all your answers are related to policypak, you might be seen as spamming. Don't forget to answer other questions, or ask some yourself! –  Journeyman Geek Aug 13 '13 at 0:55

Save this as Java32_Fix.reg and run and it will fix those javacpl.exe as Administrator / Control Panel issues once and for all:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers] "C:\Program Files\Java\jre6\bin\javacpl.exe"="RUNASADMIN"

Alternately, this is for 64bit OS's running 32bit Java:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers] "C:\Program Files (x86)\Java\jre6\bin\javacpl.exe"="RUNASADMIN"

I don't know why Sun can't get a clue and add this to their installer.. such a simple thing. Anyway, cheers, and hopefully this will help others searching for an answer to this.

Chris

share|improve this answer

This is a user permission issue and has apparently been (re-)introduced several JRE updates ago. To store your settings, you have to run the Java Control Panel in administrator mode.

Find the javacpl.exe in the bin subdirectory of your JRE installation, and use the context menu to run it as administrator. Any changes you make to the settings should now be saved when you apply and close the window.

share|improve this answer
    
Thanks for the tip, but I was already running it as an administrator. When I ran it as a regular account, the button was grayed out entirely. –  Pops Sep 22 '10 at 0:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.