Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a solution for OS X 10.6? I don't find it in the system preferences.

share|improve this question
    
What keyboard layout are you using? –  Mark Sep 22 '10 at 11:17
    
@Mark, I use Swedish-Pro. –  Andrei Sep 22 '10 at 11:30
    
Anything wrong with the answers? There's no other way than to change the layouts or live with deadkey+Space combinations. –  Daniel Beck Sep 28 '10 at 15:06
    
@Daniel, Nothing wrong. I am just not in hurry :) –  Andrei Sep 29 '10 at 20:31
    
Just wondered if the answers weren't good enough. Thanks for the accept! –  Daniel Beck Sep 29 '10 at 20:38

2 Answers 2

up vote 3 down vote accepted

You can try using Ukelele to create your own keyboard layout, without the dead key behaviour.

share|improve this answer
    
+1. AFAIK, the dead key behaviour can only be changed through the use of a utility like Ukelele to edit the keyboard input methods. –  ghoppe Sep 22 '10 at 21:17

The three characters you mention '~', '^', and [the other one that causes Superuser to do code snippet] are all on my (UK Apple) keyboard - '~'and [the other one] are on the key to the immediate right of the left shift key (I believe this is above the tab key on US Apple keyboards) and '^' is shift-6. Try turning on the "Keyboard & Character Viewer" in the input sources tab of the language and text section of System Preferences. Then select "Show Keyboard Viewer" from the menulet that appears in the top right of the screen - press the modifier keys and you'll be able to see what buttons do what.

Nontheless, to get other diacritical marks and whatnot on their own, you can press a key that can't have that accent on it. For instance, to produce '´', you can press option-e and then escape or any letter key that can't take the accent (for instance, w).

share|improve this answer
    
The problem is that if I type ~^` then I have to press something like space to fix the character, otherwise the following character will be corrected (e.g. ã), or not be displayed. This is very annoying and I hope to get rid of it since I don't use those fancy letters. –  Andrei Sep 22 '10 at 10:00
    
Can you not just use the plain keys, then? They don't require anything to be pressed after them. What input method are you using? (in the input sources tab of the language & text section of System Preferences) –  Scott Sep 22 '10 at 10:35
    
I use Swedish-Pro input method, but I notice the same problem for U.S. International-PC. There are no plain keys for this characters, I have to press Shift-smth, or Opt-smth to get them. And I want to avoid the unnecessary pressing of extra keys every time I need to type those characters. –  Andrei Sep 22 '10 at 10:57
1  
I see your problem. Using the Swedish - Pro layout, I can find single keys for everything but the tilde ('~'), though - have a poke about in the Keyboard Viewer, holding down combinations of option and shift. As for the tilde, the only thing I can suggest is re-mapping a key or switching to another keyboard layout, though the latter risks stymying your Swedish typing. –  Scott Sep 22 '10 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.