Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my ALC892, on an ASRock mainboard (ASRock 890FX Deluxe4).

I get only stereo sounds if I use SPDIF connection, in general. My amp shows that is getting surround sound only when I use the Test feature of Windows 7. This test feature allows to know which formats are supported by the audio chip. The tests render correctly both Dolby Digital and DTS. You can find this test under Sounds, Playback Devices, Select Digital Audio, then "Properties".

I am using Windows 7 x64, with the latest drivers from the official Realtek website. I also tested other driver versions, both from the Realtek website and from the ASRock one, but had no luck.

Thanks for the help.

Some specs:

  • CPU: AMD Phenom II X4 965
  • MOBO: ASRock 890FX Deluxe4 (with onboard Realtek ALC892)
  • Audio amp: Onkyo R-380 (works fine with other sources like PS3 and Xbox 360)
share|improve this question

2 Answers 2

It'll only play surround sound if the audio source you're playing is Dolby Digital (AC3) or DTS. It'll do spdif passthrough to your amp (via coaxial or optical cable). For all other sources, mp3/flac/aac, it'll be 2ch Stereo PCM only.

share|improve this answer
    
How can I test this, besides using the Windows 7 test I mentioned before? And how can I get surround sounds, for example, in games? In the options of Starcraft II I can see that I can enable surround sound, but my amp shows that is reproducing a stereo signal. Thanks anyway for your reply. –  Alex Sep 22 '10 at 14:32

I have a Creative X-Fi Titanium card (PCIe) connected with an optical cable to an AV receiver. It uses Dolby Digital Live or DTS Connect (user choice) to encode everything it sends to the amp. That way it can properly send all audio as-is, meaning same channels/frequency/etc. as the source (games, music, movies, ...).

I suggest to find a way to enable Dolby Digital Live. The top hit with a Google search is a forum post with unofficial drivers that give support for both connection options. I'm afraid the official drivers don't have support, but you could look into it.

I would also suggest you get a different sound card (PCIe) to make things easier. In the end everything will sound even better anyway. Should you decide to get a Creative card like me, I strongly advise against the bug-ridden official drivers but get the PAX Drivers instead. They're the official ones with a bunch of bugfixes and improvements. Moreover, they are properly maintained with new releases every couple of months at least.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.