Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Mac OSX 10.6.4, I'm trying to change the default application for opening .cc files from Xcode to MacVim, but Xcode or OSX won't abide. Here's a screenshot:

alt text

Notice how the clicking "Change All..." to MacVim results in the dialogue asking me to confirm the switch to Xcode - it's really hogging those files!

Why is this / is there any other way to change this?


share|improve this question
Have you confirmed that the dialog is not simply displaying the wrong App name - that if you click continue, then try to open a cc file, it will still open with Xcode? – xdumaine Sep 22 '10 at 13:01
It still opens i Xcode. Tried quitting Xcode too, doesn't work – trolle3000 Sep 22 '10 at 13:06
It worked after rebooting - guess that would have been quicker than posting the question in the first place. – trolle3000 Sep 22 '10 at 18:50

You could try setting the default application using RCDefaultApp.

share|improve this answer

If all else fails, try downloading Onyx, then going to Maintenance -> Rebuild and choosing to reset "LaunchServices". This is a bit of a drastic solution, as it'll reset all document->app mappings, but it may help you do what you need, too.

share|improve this answer
This answer should probably by HUGELY more caveated. He's going to lose ANY non-default association, and could potentially be inundated with associations problems after running that mapping reset. – VxJasonxV Sep 22 '10 at 16:11
up vote 0 down vote accepted

A reboot did the trick... obviously ;-)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .