Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a highly secured computer windows server 2003 where my outlook express is configured, i want to forward all the mails coming from Outlook to gmail. I put some auto forward rule in outlook but its not working. (May be auto forwarding is disabled).

I can forward mails manually.

Is there anyway to get rid off this problem?

share|improve this question
add comment

migrated from stackoverflow.com Aug 6 '09 at 17:55

This question came from our site for professional and enthusiast programmers.

6 Answers

I have written some VBA script to do this *bypass the server's disabling of auto-forward". Basically it mimics the user forwarding the email rather than the server doing an auto-forward.

It's pretty simple:

Sub AutoForwardAllSentItems(Item As Outlook.MailItem)
Dim strMsg As String
Dim myFwd As Outlook.MailItem

Set myFwd = Item.Forward

myFwd.Recipients.Add "[email protected]"
myFwd.Send
Set myFwd = Nothing 
End Sub

It's beyond the scope of this post to give detailed instructions, but here's a summary:

  1. Add the above code in the Visual Basic editor of Outlook (Alt-F11 should get your started). Be sure to change [email protected] to the address where you want the mail to go

  2. Tell Outlook to run this code for each inbound message (Tools -> Rules and Alerts -> New Rule -> Check Messages when they arrive -> Next -> YES -> Checkbox "Run a Script" -> Then select the script you just created.

Now Outlook should automatically forward each email you receive, but it won't be blocked by the Admin as an "Auto-forward".

share|improve this answer
    
Nitpick - the variable 'strMsg' in the code sample is never used. –  Luke Girvin Jun 11 '12 at 7:46
    
Also wanted to note one VERY big caveat with this (though it's a nice solution) -- Outlook HAS to be open when the email comes in for this to work. So if you're away from work on vacation for example, the forward won't be processed. –  JoeCool Jul 25 '12 at 17:18
add comment

I've had the same problem, and here's my solution: * Add your gmail account into Outlook * In our Outlook "Rule", instead of selecting "Forward", select "Move a Copy to a Folder" * As the target folder, select a folder in your Gmail account

share|improve this answer
add comment

Basically, with outlook and exchange you by default set up server rules. This means that the rules are applied on the server and on reception of an email regardless of whether your client (outlook) is running. With exchange it is possible to block the automatic forwarding of emails to external adresses (and it seems that your system administrators have done so). The reason it works for manual forwarding is that this is a very different process. It happens on the client, and for the server it looks like just sending any other email.

The reason for such configuration of the server is generally to prevent corporate information and secrets to be leaked out. As this is a valid concern, you probably won't have luck convincing your admins to let you forward your emails to gmail.

share|improve this answer
    
i could see my auto forwarded messages in sent item, but its not reaching in my gmail inbox –  Jaison May 19 '09 at 9:23
    
This probably means that the blocking happens at a different stage. The outward email can be configured to go through a gateway server that blocks things. That would mean that the originating server things it is sent (and puts the mail in your sent mail folder), but that the intermediary blocks things from going out. –  Paul de Vrieze Jun 27 '09 at 20:45
add comment

You might want to consider adding the email accounts you want to forward to gmail via the accounts tab. You can add both POP and IMAP accounts now.

share|improve this answer
    
which email account i need to add, my email account is already configured in outlook –  Jaison May 19 '09 at 9:13
    
You mean to say if i configure my gmail account in the outlook it will work ? –  Jaison May 19 '09 at 9:26
add comment

The easiest way would be to ask your mail server admin to set up a server-side forward to your GMail account.

Otherwise, as Mr Matt suggests, adding the account directly to GMail is likely to prove most efficacious.

share|improve this answer
    
This is not possible, and i am not doing anything illegal here because i am a contractor i just want to get it to my offshore email inbox –  Jaison May 19 '09 at 9:25
    
I'm interested that you say it's not illegal, because nobody seems to be suggesting you are. Although now that you bring the subject up... –  Dave Arkell Jun 9 '09 at 12:53
add comment

I don't know what you mean by auto forwarding rule, but have you added it as a normal filter / rule in your email filtering? There is an option there to forward or forward as attachment.

share|improve this answer
    
i could see my auto forwarded messages in sent item, but its not reaching in my gmail inbox –  Jaison May 19 '09 at 9:23
add comment

protected by random Feb 17 '11 at 19:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?