Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way to make Emacs partially transparent in kde4? I tried some of the solutions proposed online, but none of them had any effect at all; I suspect it might be an issue with kde, but I am not actually sure.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Have you tried setting the application-specific KWin settings for Emacs? If you right-click the title-bar of Emacs, and select Advanced->Special Application Settings, you should get app-specific settings which will be used whenever Emacs opens. I selected "Active Opacity %" in the "Preferences" tab, set it to 75, and selected "Force" in the drop-down. Emacs now comes up with 75% opacity whenever it launches.

Note: I'm using KDE 4.4.


Edit: Just for reference: a brief search for Emacs + transparency came up with this. I didn't have any luck with Emacs' settings either.

share|improve this answer
    
That works--I didn't even think of doing it that way. –  Tikhon Jelvis Sep 22 '10 at 22:23
    
That said, a way of doing it from emacs so that I can control it through emacs would be nicer, but beggars can't be choosers. –  Tikhon Jelvis Sep 22 '10 at 22:24
    
@Tikhon, agreed, but I wonder how much control Emacs may assert over the actual window itself. I would expect that to be solely under the control of KDE, though I may be wrong :^) –  bedwyr Sep 23 '10 at 2:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.