Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had to restore my Mac today from a Time Machine backup. Everything went swimmingly, except for now I can't seem to unzip files using Archive Utility.app. Wherever I try to unzip files on my 'Macintosh HD' volume I always get the error:

Error identifying a writable temporary folder. Try moving the archive to another volume.

However, if I move the archive to one of my Firewire external drives and unzip it from there, it works.

I've tried the standard Repair Disk Permissions from Disk Utility, using the diskutil repairpermissions / command and booting into my install disk and trying both of the previous from there. Unfortunatly it didn't solved the problem.

Any more suggestions would be ace as I can't seem to find anybody with the same issue via Google. Thanks in advance!

share|improve this question
    
What do you mean by "on my 'Macintosh HD'"? The root path /? Or also in your home folder /Users/username/? Has your user account administrative privileges, is FileVault activated and what are the permissions of the folder where the archive is located? –  Daniel Beck Sep 23 '10 at 5:53
    
By Macintosh HD I am referring to any folder under the root path /. I've tried moving the zip file around to other folders and unzipping it from there, but I get the same error message. Could this be an issue with my /private/tmp and /private/var folders? Those folders both have the permissions drwxrwxr-x. –  greenie Sep 23 '10 at 7:16

3 Answers 3

An answer on discussions.apple.com that worked for me:

cd /var/folders
sudo rm -rf *
share|improve this answer
    
This worked for me. I don't have access to the install disk since this is my work laptop. This worked like a charm. –  pthurmond Oct 22 '12 at 15:59

I've just had this same problem. After poking around a bit, it turned out that something had created a root-owned directory in my temp folder, Cleanup At Startup. Changing the ownership of everything in my temp folder allowed archive utility to work as normal.

From the terminal, do:

$ sudo chown -R $USER $(dirname $(mktemp -t foo))

And try opening an archive from the finder again.

share|improve this answer
up vote 1 down vote accepted

I managed to fix my problem by sticking in my Snow Leopard install disk and reinstalling Snow Leopard. It kept all my files and applications but seems to have fixed my permissions issues.

share|improve this answer
    
You could mark your own answer as correct so that it's recognizable as solved! ;) –  BloodPhilia Sep 23 '10 at 13:36
    
I tried to already but it won't let me do that until tomorrow :( –  greenie Sep 23 '10 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.