Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have windows 7 & i want to share my broadband internet connection with my husbands laptop, which has wifi. i have tried lots of ways to set up the connection. on my desktop there is no share button under my network. nor is there a ad hoc or computer to computer option under set up a connection or network. i don't have bluetooth or wifi on my desktop

share|improve this question
2  
If you have neither Bluetooth nor Wi-Fi, how do you plan to share the connection? –  waiwai933 Sep 22 '10 at 22:13
1  
@waiwai933: I don't believe he grasps the concept of both computers needing a wireless card to use a wireless connection. –  Hello71 Sep 22 '10 at 22:16

5 Answers 5

Ad-Hoc is purely a networking option designed to connect two computers over a wireless connection - it is typically insecure and not advised. If your machine does not have wireless, you will not see this option.

However, most broadband providers give you a wireless router, so if you do have one, you should be able to connect your husbands laptop directly in to that. Try looking at your documentation or the box itself to see if you have a sticker with the connection details (Network name and key).

Alternatively, if you have an older style router with just one connection you may be out of luck. If it is USB, then you can buy a cross over network cable (or in some situations, a standard ethernet cable works, so if you have one lying around, try that first) - then simply run the network and sharing wizard, and it should guide you through sharing the connection.

If the router only has one ethernet connection and that is plugged to your PC, you will not be able to do anything as the port is used up.

If the router has more ethernet ports and no wireless, you can plug your husbands laptop straight in to that.

Failing this, your best option with the least hassle is to buy a new wireless ethernet/cable router (e.g. NON modem) this will allow you to plug your current modem/router (if it only has one ethernet out) in to it, then it basically gives you extra ethernet ports and wireless ability.

Lastly, you can buy a USB wireless adapter for your desktop and share over Ad-hoc but I would not recommend this as it lacks security, and your machine has to remain on to share.

I have said a lot here, but if it is confusing at all or you need further help - please write a comment and I will try my best to help you!

share|improve this answer

Get yourself a broadband router with wireless built-in or if you already have a router with a multi-port switch, just get a wireless access point. You can then use a wired connection and hubby can use wireless

share|improve this answer

Control Panel > Network and internet > Network Connections

Select the two network connections (wired and wireless), right click, chose bridge connections.

This will allow either to connect through the other.

share|improve this answer

You can set up an Ad Hoc network in W7, go to Networking and sharing Center and click "set up a new connection or network" there will be adhoc options in there.

share|improve this answer

I had a similar problem. Creating an ad-hoc connection, you can connect your phone or any other wireless capable device to your laptop and share internet.

In my case, I was using this connection until last night and today I found out there is no ad hoc connection option in setup new connection. It happened so because I had disabled the wireless adapter accidentally. Now that I have enabled it, my connection is working fine.

In case, you have a wireless adapter on your desktop machine, you may want to check if it has been disabled for any reason.

share|improve this answer
1  
Looking at the question, I don't think she has a wireless card on her desktop machine. In which case your answer isn't valid at all. –  darnir Sep 26 '12 at 10:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.