Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have VLC on my Mac and would like to connect to a DLNA server on my LAN but the server isn't showing up in VLC's UPnP auto-discovery UI. Given the IP address of the server how can I point VLC to it explicitly so it can be 'discovered'?

share|improve this question
    
VLC may have changed a bit since you asked, but I'd make sure you were on the same ethernet segment and use wireshark to check your client is receiving the announcements. I also found it took a minute or two for all the music to propagate. –  Andrew Apr 11 '11 at 11:40

2 Answers 2

up vote 37 down vote accepted

Read this thread.

What worked for me was to go to Tools → Preferences → All → Playlist → Services and Discovery, and enable Universal Plug and Play (UPnP).

Then go to VLC main menu and click View → Playlist and scroll down to Local Network. Locate Universal Plug and Play and click on it.

A few moments later your media service should be shown on the main window to the right. If you click on it (or double click) then it will start showing you all the folders/files being served. Give it time as it took mine almost 30 seconds to show everything.

share|improve this answer
23  
There is no "Universal Plug and Play" option in VLC 1.1.11 that I can find. –  andyczerwonka Jul 19 '11 at 1:57
    
+1 Worked for me! Thanks. –  Geoff Jul 24 '11 at 0:12
28  
In VLC 2.x you can skip the Tools process and directly go to View -> Playlist -> Local Network -> Universal Plug'n'Play to get the DLNA devices on your network listed and stream from them. –  Koen Zomers Apr 30 '12 at 0:19
1  
Unfortunately in the current 2.1.3 windows version, the UPnP doesn't work well. –  tftd Jun 16 at 23:37

It is planned that VLC 1.2.0 get's back UPNP (DLNA) support. Since 2011-08-04 the nightly builds of VLC should include it again in a more or less working state. In the menu bar select "View" and then "Playlist". In the new window click on the "triangle" before the text "Local Network" on the left. The menu is expanded and there you should see the entry "Universal Plug'n'Play". Now select "Universal Plug'n'Play" and wait...it takes at least 20 seconds (but may also take some minutes until the server shows up).

So far there doesn't seem to be an option to manually add the server ip including the port. I would like that too because I don't want to announce to the whole world via port 1900 that my server offers music/pictures/videos.

Here the link to one Windows build known to work (more or less). You can always try newer builds but keep in mind that those are all "unstable" and might have some issues. http://nightlies.videolan.org/build/win32/trunk-20110804-1935/

share|improve this answer

protected by Community Dec 3 '11 at 17:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.