Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I downloaded the DejaVu font, and installing the TrueType (.ttf) files to C:\WINDOWS\Fonts enabled me to use them in EmEditor.

How can I make Vim and Emacs to use this font as the default?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

VIM

From http://www.netlinxinc.com/index.php?option=com_content&task=view&id=45&Itemid=2:

The Windows version of VIM that I am using is the Win-32 console and OLE GVIM flavor. Assuming you took the defaults during the installation of the program, you will find the VIM init file in the %DRIVE%\Program Files\Vim called _vimrc. Edit this file and add a line that looks like the following:

set guifont=Lucida_Console:h10

This will use the Lucida Console font in size 10 regular. You can use other fonts, sizes and settings. The syntax is basically:

set guifont=font-family:size:style

Emacs

Set

(set-default-font "XLFD")

in your .emacs file where XLFD is the X Logical Font Description. How to get that is described here: http://www.gnu.org/software/emacs/windows/Fonts-and-text-translation.html#Fonts-and-text-translation

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.