Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Solved, see my comment on the accepted answer below, the problem had nothing to do with drivers.

I've bought an eSATA enclosure and put a drive in it, and I'm just having no luck getting my Ubuntu 10.04 LTS desktop (64-bit) to recognise it via eSATA. It works fine if I use the same enclosure via its USB2 connector instead, which tells me that the drive is installed in the enclosure successfully and that the drive works.

Here's what I've tried / checked:

  1. Connecting the drive naively. Literally, plugging the eSATA cable into the box and turning the drive on, while Ubuntu was running. No reaction, and nothing shows up in the Disk Uility or fdisk -l.

  2. Leaving the drive connected and cold booting Ubuntu from poweroff. Still nothing on DU or fdisk -l.

  3. Ensuring that the BIOS has the eSATA port enabled (it did, I didn't have to change it).

  4. Ensuring that the BIOS is using AHCI. It wasn't, and that hadn't been any problem accessing the internal SATA SSD (the box's primary drive). (The SSD showed up under the PATA controller, because I think the BIOS was doing emulation or something.) Switching the BIOS to use AHCI on the SATA controller didn't make any difference other than that the SSD showed up under the SATA controller instead and was listed as using the ahci driver, as you'd expect.

  5. Looking in dmesg for anything useful. I don't see any mention of the drive at all (except from when I had it attached via USB).

Other info:

  • eSATA is on the motherboard, an Intel DH57JG.
  • Enclosure is an Apex (cheap, but other than cable length issues people on Amazon seemed to like it, and it's handsome).
  • Drive is a Samsung F3 HD103SJ.
  • Cable is, well, a cable.

Unfortunately, I don't have any other machine that supports eSATA so I can do the obvious thing and prove that the rig (enclosure and cable) work over eSATA on another box. :-( And I don't have my desktop set up to dual-boot another OS... So at this stage, I don't know it's a software problem, could be hardware, could be cable, but in case there's something obvious I'm missing...

Update 1:

hotei suggested I may need specific drivers for the board (the Intel H57 chipset in the DH57JG), but Intel seems to think that the kernel already supports the chipset natively. I have to say it never occurred to me that the internal SATA would work and eSATA wouldn't.

Update 2:

Someone over on the Ubuntu forums suggested installing scsitools and running rescan-scsi-bus.sh as root, just in case. No luck, but posting that info here for completeness:

root@forge:~# rescan-scsi-bus.sh -c
Host adapter 0 (ahci) found.
Host adapter 1 (ahci) found.
Host adapter 2 (ahci) found.
Host adapter 3 (ahci) found.
Host adapter 4 (ahci) found.
Host adapter 5 (ahci) found.
Scanning SCSI subsystem for new devices
Scanning host 0 channels 0 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning for device 0 0 0 0 ...
OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: INTEL SSDSA2M080 Rev: 2CV1
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning host 1 channels 0 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 2 channels 0 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning for device 2 0 0 0 ...
OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 00
      Vendor: TSSTcorp Model: CDDVDW SN-S083C  Rev: SB01
      Type:   CD-ROM                           ANSI SCSI revision: 05
Report Luns command not supported (support mandatory in SPC-3)
Scanning for device 2 0 0 0 ...
OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 00
      Vendor: TSSTcorp Model: CDDVDW SN-S083C  Rev: SB01
      Type:   CD-ROM                           ANSI SCSI revision: 05
Scanning host 3 channels 0 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 4 channels 0 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 5 channels 0 1 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
0 new device(s) found.               
0 device(s) removed.                 

Any ideas?

share|improve this question
    
I had a similar problem, one SATA DVD and one IDE DVD. The SATA was set as primary, would boot the ISO DVD but would not be avalable to complete the installation. I had to boot with SATA drive, remove DVD and put it in the IDE drive to install Ubuntu. Five years later, still trying to find and install driver for Plextor 712 SATA DVD. –  user220802 Apr 29 '13 at 16:59

2 Answers 2

up vote 1 down vote accepted

See if this helps : HOWTO: Hot-swap eSATA drives.

See also Mounting of eSATA drive (and especially the last entry).

share|improve this answer
    
Thanks. Your first link is about dealing with automount and such; my problem is more basic, the drive isn't recognised at all. It does talk about scsiadd, which I did try, but scsiadd looks like it covers similar ground to the scsitools I already tried. The second link is interesting. What I really need to do is double-check the physical link somehow. Sadly nothing in the BIOS to do it, at some point I'll try to walk through enough of the Windows install to see the drives without (ideally) actually blowing away the data. (With a full backup beforehand, of course.) –  T.J. Crowder Sep 28 '10 at 9:02
    
The problem had nothing to do with drivers! It was that the backplate of the box is poorly-fitted and pushes the eSATA connector out. I'd read this post in your second link, and looked to be sure it was fitted securely, but didn't apparently try hard enough, because if I stand there and forcibly push the connector in and keep holding it, it works. Giving you the answer because of that link, thanks! –  T.J. Crowder Sep 29 '10 at 11:31

At first blush I'd say there are no drivers in Ubuntu 10.4 for the eSATA on your motherboard. It would seem eSATA is just enough different from regular SATA to require it's own drivers. I've run into the same issue with eSATA on a PCI card. My eSATA drive was recognized by XP but not Ubuntu.

A somewhat old link, but it indicates this has been a problem for a while: http://brainstorm.ubuntu.com/item/6607/

share|improve this answer
    
I was really hoping that wouldn't be it. :-| –  T.J. Crowder Sep 23 '10 at 18:39
    
Actually, Intel thinks that the chipset is supported natively (e.g., in the kernel): intel.com/support/motherboards/desktop/dh57jg/sb/CS-031531.htm Just updated the question with that info. –  T.J. Crowder Sep 24 '10 at 8:20
    
@T.J.: I just read your Intel link and didn't come to the same conclusion you did. I don't see where Intel says eSATA is supported natively by Linux. I hope it's true, I just don't see it explicitly. –  hotei Sep 24 '10 at 14:06
    
Yeah, it doesn't say it explicitly, it just talks about the chipset being supported -- but what "supported" means (and what part of the chipset)... It also says the storage driver is supported, but again, that may just mean the internal, not eSATA, stuff. :-( –  T.J. Crowder Sep 24 '10 at 14:14
    
@T.J: Hope I'm wrong, but your comment above is exactly what crossed my mind. I've got you favorited 'cause I've got two eSATA capable enclosures I currently have to run with USB. :-( –  hotei Sep 24 '10 at 14:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.