Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install VMWare tools on Debian Squeeze.

My error:

Before you can compile modules, you need to have the following installed... 

kernel headers of the running kernel

Searching for GCC...
The path "/usr/bin/gcc" is not valid path to the gcc binary.
Would you like to change it? [yes] 

uname -a:

Linux debian 2.6.32-5-686 #1 SMP Sat Sep 18 02:14:45 UTC 2010 i686 GNU/Linux

dpkg -l | grep make

ii  make                                 3.81-8                               An utility for Directing compilation.

dpkg -l | grep gcc

ii  gcc                                  4:4.4.4-2                            The GNU C compiler
ii  gcc-4.4                              4.4.4-8                              The GNU C compiler
ii  gcc-4.4-base                         4.4.4-8                              The GNU Compiler Collection (base package)
ii  libgcc1                              1:4.4.4-8                            GCC support library

whereis gcc

gcc: /usr/bin/gcc /usr/lib/gcc
share|improve this question
Make sure you also have libglib2.0-0 installed. – user109405 Dec 13 '11 at 17:05

Running this command fixed the problem:

sudo aptitude install gcc-4.3 make linux-headers-`uname -r` -y
share|improve this answer
@WarrenP make is one of the packages that needs to be installed (see edit history, revision 4), not a separate command. I've reverted your edit. – Indrek Jan 4 '13 at 15:53
oh. My bad! thanks – Warren P Jan 6 '13 at 15:55

Like Guillaume said in OP's comment:

sudo aptitude install libglib2.0-0
share|improve this answer
Had the same problem on a clean debian installation. The library was missing. – CSchulz Sep 8 '13 at 0:35

I've had the same problem for a while now. I tried all these steps and others. Failure after failure, but I am persistent. I did figure out how to do it on my machine*. From all the sites and installs I've been to and done, I had everything I needed. I had to point the VMWare gcc ver. to /usr/bin/x86_64-linux-gnu-gcc-5. It went through the last steps of install, but wouldn't start. I exited the program, restarted it and viola! It worked. If this worked for you, please copy and paste it everywhere you've been looking for answers. Thanx 2 all!

* Operating System Version Kernel
Linux 4.4.0-040400-lowlatency (x86_64)

Computer Processor:
8x Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz - O.C. to 4Ghz


Operating System:
Linux Mint 17.3 Rosa

Display Resolution:
1440x900 pixels

OpenGL Renderer:
GeForce GTX 750 Ti/PCIe/SSE2

X11 Vendor:
The X.Org Foundation

Multimedia Audio Adapter:
HDA-Intel - HDA Intel PCH

Audio Adapter:
HDA-Intel - HDA NVidia

Input Devices:
Ideazon Merc Stealth
2.4G Wireless Device
HDA Intel PCH Front Mic HDA Intel PCH Rear Mic
HDA Intel PCH Line
HDA Intel PCH Line Out Front
HDA Intel PCH Line Out Surround HDA Intel PCH Line Out CLFE HDA Intel PCH Line Out Side HDA Intel PCH Front Headphone
HDA NVidia HDMI/DP,pcm 3= HDA NVidia HDMI/DP,pcm 7= HDA NVidia HDMI/DP,pcm 8= HDA NVidia HDMI/DP,pcm 9= Printers No printers found
ATA ST380815AS
Generic- SD/MMC Generic- Compact Flash
Generic- SM/xD-Picture
Generic- MS/MS-Pro

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.