Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All my desktop shortcuts look like the Word icon. When I use a shortcut to try to open a program, Word 2010 opens and then it tries to open the program so a file conversion window appears! What's going on? How do I get the shortcuts back?

share|improve this question
    
Have you tried System Restore? –  paradroid Sep 23 '10 at 22:22
add comment

5 Answers

Sounds like somehow all of your file associations got mixed up (or more accurately they're all assigned to Word). It's a bit of a hassle, but your best bet is to change the associations one at a time, on an "as needed" basis.

What you do is right-click the file in question, say: mynotes.txt, and hover over the Open With menu, and select Choose default program. You can then select the program that you want to open it with (from then on). Just make sure that Always use the selected program to open this kind of file is ticked on the 'Open with' dialog.

If you want to get down and dirty, you can also go to the control panel, and search for 'File Associations' and select the `Change the file type associated with a file extension' item. There you can change all the associations on the system.

Unfortunately I don't know of a simple and safe way to reset all assocations all at once.

share|improve this answer
add comment

You may import following registry hives from "good" computer (where links are working OK):

[HKEY_CLASSES_ROOT\.lnk]
[HKEY_CLASSES_ROOT\lnkfile]

OR In case you have not machine with Win 7 where it works nearby, you may save text below into a file with .reg extension and import it into registry via duble-click on this file.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.lnk]
@="lnkfile"

[HKEY_CLASSES_ROOT\.lnk\ShellEx]

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214EE-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{000214F9-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{00021500-0000-0000-C000-000000000046}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\.lnk\ShellNew]
"Handler"="{ceefea1b-3e29-4ef1-b34c-fec79c4f70af}"
"IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\
00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,\
31,00,36,00,37,00,36,00,39,00,00,00
"ItemName"="@shell32.dll,-30397"
"MenuText"="@shell32.dll,-30318"
"NullFile"=""
"Command"=-

[HKEY_CLASSES_ROOT\.lnk\ShellNew\Config]
"DontRename"=""

[HKEY_CLASSES_ROOT\lnkfile]
@="Shortcut"
"EditFlags"=dword:00000001
"FriendlyTypeName"="@shell32.dll,-4153"
"NeverShowExt"=""
"IsShortcut"=""

[HKEY_CLASSES_ROOT\lnkfile\CLSID]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\OpenContainingFolderMenu]
@="{37ea3a21-7493-4208-a011-7f9ea79ce9f5}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\ContextMenuHandlers\{00021401-0000-0000-C000-000000000046}]
@=""

[HKEY_CLASSES_ROOT\lnkfile\shellex\DropHandler]
@="{00021401-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\lnkfile\shellex\IconHandler]
@="{00021401-0000-0000-C000-000000000046}"

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.lnk\UserChoice]
share|improve this answer
add comment

You could try File Association Fixer

share|improve this answer
add comment
  1. Go to start menu.
  2. Run command
  3. regedit in run command.
  4. HKEY_CURRENT_USER\\software\microsoft\windows\currentversion\explorer\filexts\
  5. Search for .lnk ext.
  6. Delete whole .lnk key or delete the userchioce key on that.
  7. Just restart.
share|improve this answer
add comment

This is how I resolved the problem:

  1. Open the Run dialog (Start → Run or Ctrl+R)
  2. Type regedit, the click [OK]
  3. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts
  4. Look for a .lnk branch
  5. If you find one, delete it
  6. Reboot
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.