Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All my desktop shortcuts look like the Word icon. When I use a shortcut to try to open a program, Word 2010 opens and then it tries to open the program so a file conversion window appears! What's going on? How do I get the shortcuts back?

share|improve this question
Have you tried System Restore? – paradroid Sep 23 '10 at 22:22

Sounds like somehow all of your file associations got mixed up (or more accurately they're all assigned to Word). It's a bit of a hassle, but your best bet is to change the associations one at a time, on an "as needed" basis.

What you do is right-click the file in question, say: mynotes.txt, and hover over the Open With menu, and select Choose default program. You can then select the program that you want to open it with (from then on). Just make sure that Always use the selected program to open this kind of file is ticked on the 'Open with' dialog.

If you want to get down and dirty, you can also go to the control panel, and search for 'File Associations' and select the `Change the file type associated with a file extension' item. There you can change all the associations on the system.

Unfortunately I don't know of a simple and safe way to reset all assocations all at once.

share|improve this answer

You may import following registry hives from "good" computer (where links are working OK):


OR In case you have not machine with Win 7 where it works nearby, you may save text below into a file with .reg extension and import it into registry via duble-click on this file.

Windows Registry Editor Version 5.00

















share|improve this answer
  1. Go to start menu.
  2. Run command
  3. regedit in run command.
  4. HKEY_CURRENT_USER\\software\microsoft\windows\currentversion\explorer\filexts\
  5. Search for .lnk ext.
  6. Delete whole .lnk key or delete the userchioce key on that.
  7. Just restart.
share|improve this answer
Worked like a charm! – Learner Aug 29 '14 at 19:59

You could try File Association Fixer

share|improve this answer

This is how I resolved the problem:

  1. Open the Run dialog (Start → Run or (Win)+R)
  2. Type regedit, then click [OK] or type Enter
  3. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts
  4. Look for a .lnk branch
  5. If you find one, delete it
  6. Reboot
share|improve this answer the RUN dialog Box

2.Type There regedit


4.find .lnk

5.Delete userChoice

share|improve this answer
Looks a lot like the answer from 1½ years ago. – G-Man Mar 4 '15 at 10:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.