Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I think I have finally arrived at an insolvable equation:

Chromium v.7 + Ubuntu 10.04 + Sun Java 6 + Webcam + Facebook + Flash 10 = non-functional

All of those items listed above are potential points of failure in this situation, and any help narrowing them down would be fantastic. I am simply trying to enable webcame support directly through Facebooks website.

Forum searches and the usual googling turn up few posts related to this specific equation. Two of the major suggestions include:

1) Installing the Sun (I refuse to say oracle sob)-provided Java implementation instead of the OpenJDK normally installed in Ubuntu. And yes, after installing it, I did update all my default supports to use the sun commands over the openjdk.

2) Somehow enabling Facebook as a permitted site to access my webcam using Flash settings.

I have not been able to explore option 2 because I cannot find a way to adjust the Flash settings in chromium 7.

Other factors that do not help include the fact that I am pretty sure facebook changes its webcam interface every 10 seconds just to keep troubleshooters and support personnel on their toes. If anyone has a OTP that informs us of the next shift in the app, a leak would be greatly appreciated!

share|improve this question
1  
I'd install Cheese first and see if the Webcam is being detected @Jonathan –  Sathya Sep 24 '10 at 13:55
    
cheese works fine, though as usual, camorama struggles –  Jonathan Sep 27 '10 at 3:38
2  
To everyone voting to close for WebApps. Not every question referring to WebApps needs to be migrated, some questions, like this one, is 100% valid for SuperUser. –  Diago Oct 11 '10 at 18:25
    
Haha, I voted to close it, personally, because it's my own question and no one seems to want to answer it. I have no problem keeping it open, and had hoped it was SU appropriate. –  Jonathan Oct 12 '10 at 10:52
    
problem still persists. Some updates: now using the "officially stable" chromium 7, fresh install of ubuntu netbook 10.04, and back to the default ubuntu java, openjdk. –  Jonathan Oct 22 '10 at 6:59

2 Answers 2

I have a similar setup (Mint instead of Ubuntu, Chrome instead of Chromium) I (mostly) solved the problem by accessing the "Website privacy settings panel", which is a control panel of the local Flash player which is accessed through the browser. Her is the link I used:

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html

find www.facebook.com in the list of websites and change the setting to 'always allow' This isn't ideal, since maybe you don't want it ALWAYS allowed, but it got the darned thing working, so, you know, better than nothing. I hope this helps.

share|improve this answer

Easy. Where the webcam starts to load in facebook go to global settings click on Camera and Mic Settings by site, where it says facebook if it says ask me, change it to allow and refresh the browser and it will work. =]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.