Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a RAID FireWire external hard drive enclosure bought for me that supports four drives.

Awesome I thought and put all my hdd's in it without a second thought, tried to use it and it the "disk wasn't readable". Fair enough I thought, guess I have to fiddle with the RAID settings etc...

I take the hard drives out put them back in my main PC and now it won't boot, so I plug one of the drives in on an external usb cable and look at it using W7 on my MBP, the entire hard drive is unallocated?!?

So I don't seem to be able to get at all my precious precious data?!?

What is the best way to go about recovering it, I'm presuming it's still there I don't know why it would have been formatted, is the MBR or the boot table just missing and needs a rebuild?!? Please offer all advice!

Extra Info: The even more annoying bit is that as these are my four main HDD's all of my data is backed up onto each of them, only a few really important bits I have stored online!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Raid 0 stripes data over all the disks, so I suspect your enclosure assumes disks added are blank and makes them ready to build a 0 partition.

You could check out: http://superuser.com/questions/137351/data-recovery-from-unallocated-harddisk-partition

for some suggestions on trying to recover the information. Alternately you will have to resort to recovering your data from your backups.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.