Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I downloaded software (Skype), installed it everything works fine. The only annoying thing is that the dmg image always appears after rebooting. I'm new to Mac OS X.

EDIT: It's exactly as described here http://www.tuaw.com/2007/05/02/mac-101-dmg-files-are-disk-images/ but it reappears after reboot.

share|improve this question
    
Do macs have something like an autostart folder? –  stacker Sep 24 '10 at 19:58
add comment

3 Answers

up vote 3 down vote accepted

The same thing happened to me shortly after I moved to a Mac. I made the same mistake you probably did: I ran Firefox from its .dmg file, and every time I ran it, the .dmg re-opened on my desktop. The way to install an application on a Mac (once you have downloaded it) is to:

  • Open its .dmg
  • Drag the application file inside it to your or the system's applications folder
  • Drag the application's icon from the application folder (not from the .dmg) to the dock, if you want it there
  • Right-click or cmd-click the .dmg file and eject it.
  • Delete the .dmg file - it was just a shipping container.

For your currently sort-of-installed Skype, right click the Skype icon on the dock, select options, and uncheck "Open at Login". Drag the Skype icon off the dock (it goes poof! and disappears). Re-do the install as above. If you want it to start whenever you log in, use the dock icon again to select that option.

share|improve this answer
    
Thanks, I double checked everything, but I've no idea from where the dmg comes, the installation procedure is now clear. I rebooted five times since I asked this question. Maybe I dropped it by accident somewhere like an autostart folder or something. –  stacker Sep 24 '10 at 20:33
2  
Look for Skype in System Preferences | Accounts | <youraccount> , on the Login Items tab, in the list of applications to be run at startup. (This is the likely 'Autostart' place). If you find it there, right click it and and select Reveal in Finder. That should show you where Skype is being loaded from, if it's not from the installed application (maybe it's still being loaded from the .dmg in the trash). If you find it is being loaded from somewhere other than your or the system's Applications folder, delete it from the Login Items list [to be continued.....] –  JRobert Sep 25 '10 at 15:31
1  
[Continuing....] (select it and click the minus-sign button below). Close System Preferences. Run Skype from whichever Applications folder you installed it to, and use the dock Icon (as in my answer above) to set the Open at Login option. –  JRobert Sep 25 '10 at 15:37
    
thanks for you instructions, although I deleted it first following dtlussier , I found the evil doer as you described in the account settings. –  stacker Sep 25 '10 at 19:35
add comment

A few questions to try and figure out what is going on:

  1. When you installed the Skype app, did you drag it to the Applications folder?

  2. Are you running Skype from the disk image, rather than from your hard drive?

  3. When you say reappear, where does it reappear? As as .dmg file in the Downloads folder? As a mounted disk image in the disk area (i.e. top left-hand corner) of Finder?

share|improve this answer
    
Thanks for your response:1. Maybe I did this wrong in my first 20 minutes, I removed the file and installed it by dnd. 2. It seems like the image file is always placed on desktop after reboot, even if I removed it using finders eject. 3. It appears as a disk image on the desktop (the background image, in case it means something different on mac). –  stacker Sep 24 '10 at 19:54
    
See the response from @JRobert. The process of installing an app is well described there. –  dtlussier Sep 24 '10 at 20:28
    
Ok - so you're still getting the reappearing .dmg on the Desktop? Try deleting it, emptying the trash and then rebooting. If that doesn't work and you're familiar with the Terminal, do cd ~ and then find . -name "*.dmg" which will look recursively though everything below your home for disk images. Please post the results. –  dtlussier Sep 24 '10 at 21:52
    
Thanks, I removed it using the shell (bash), and it now no longer appears after reboot. –  stacker Sep 25 '10 at 19:26
add comment

I had a similar issue with a DMG file sitting in Places within my Finder. I couldn't seem to delete or remove the file - regardless of what I did. Same as the person above, when I right clicked on the item, it brought up the preferences for finder. If I double clicked on the item, it told me that it couldn't find the file.

I am assuming that somewhere along the line, I installed the software, somehow dragged the .dmg file into the places section and then had deleted / ejected the original DMG File -- leaving the file in my places.

After thinking about it a bit, I went searching for the original file on the net which I strangely couldn't find. It was some random installer for WebEx software that I think auto installed when I participated in a webex conference.

So, I tried to trick it. I renamed another .dmg file to the same name as the ghost file and then double clicked to open it. The .dmg file showed up in my 'devices' section -- actually with the correct .dmg info, not the renamed file.

HOWEVER, now when I right clicked on the ghost file, it gave me the option to remove the item from the sidebar -- which is what I wanted to do. I then ejected the .dmg file and problem solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.