Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had a love hate relationship with my Drobo for a long time. After two years of using it on a Linux box, I moved it over to a Windows 7 machine where it seemed to work just fine for a long time, but it was under very light usage. Mainly backups that never actually happened.

Recently I began using it for additional backup services (through CrashPlan, which is great). This means the Drobo gets a lot more usage. Also it means that something interesting happens, the Drobo can choke my system on startup. Here's what I mean:

Start computer without Drobo plugged in, CrashPlan and Drobo Dashboard services disabled: 105s Start computer with Drobo plugged in Crashplan disabled, Drobo Dashboard enabled: 250s (and 1 cpu at 100% for a very long time, drobo churning) Start computer with Drobo plugged in, CrashPlan and Drobo Dashboard disabled: 250s (1 cpu at 100% for a very long time, drobo churning) Start computer with Drobo plugged in, Crashplan and Drobo Dashboard enabled: 300s (1 cpu at 100% for a very long time, drobo churning)

If I yank the USB plug on the Drobo the CPU usage goes down to nothing very quickly. The slow startup in the fourth scenario is because CrashPlan is trying desperately to load stuff up on the H: drive before it gives up, so I've disabled it for the time being.

So here's my question: What the heck is going on when I plug the drobo in? I've fired up Process Explorer and see that the System process is hogging the CPU, specifically it's an ntoskrnl.exe/KdPollBreakIn thread that's going ape.

Is this something that's wrong with Drobo? Windows? Any idea on how to find out?

If it matters, here's tech info: Athlon 64x2 4400, 2GB RAM, Win7 Ultimate, Drobo USB (2x1TB, 2x320GB)

share|improve this question
Might be some expert Drobo users on the Drobo forum...drobospace.com/forums –  Moab Sep 25 '10 at 1:09
I've just run into the same problem. Might be related to support.datarobotics.com/app/answers/detail/a_id/163/related/1 –  Jesse McGrew Oct 12 '10 at 6:43
@Jesse: I admit I did once run the Windows Backup tool on the Drobo. After that I had to completely reset and reformat the Drobo -- this still didn't fix it. Switching to 4TB volumes seems to have fixed it, although now my Drobo presents itself as two drives. –  Pridkett Dec 23 '10 at 15:57

3 Answers 3

I think I might have found a solution.

  • In Windows 7 open the Start menu
  • Type system
  • Select 'System' from the results
  • Select 'System Protection' from the left column
  • Select your Drobo and click 'configure'
  • Make sure your Drobo is set to 'turn off system protection'
  • Click the 'Delete' button that deletes all restores.

After doing this I also went into the Drobo, and changed the view settings so I could see protected hidden files. Inside is a folder called System Volume Information.

I opened it and deleted (or tried as it repopulates itself from what I've read) everything inside, and then the folder itself.

Now my Drobo seems to be working normally again, I only got one chance to try it out so far but I think it works. Try it out and report back if it works for you.

share|improve this answer

Don't use Windows 7 image backup with Drobo.

I've been happy with my DroboS eSATA until I recently performed an Image backup using Windows 7. This essentially bricked the unit, plus, the computer freezes when connected to the DroboS. I can't use the computer and can't use the DroboS.

After 4 hours it finally unfroze enough so that I could see ONE of the DroboS drives, so I contacted Drobo tech support and was informed that they have a KB article, #163, dated Feb, 2012, titled:

My Windows 7 computer hangs or is slow to boot when connected to a Drobo storage device. What should I do?

This explains that you should not use Windows 7 backup with a Drobo unit. Given that Windows 7 Backup apparently creates some partitions that the DroboS can't deal with, and given that it will freeze your computer, and given that it makes your DroboS worthless, and given that the only "solution" is copy your "X" terabytes of data off your DroboS and store it somewhere else (now where might that be?) and reformat the DroboS (start from scratch, with almost 4 Terabytes of data?)… this is a major company policy fail.

They told me it's Microsoft's problem... well, no, it's not, it's my problem, and consequently Drobo's problem. My whole business is down until I resolve this issue. It means that I will have to purchase a storage device that can hold the data currently on the Drobo (you can bet it won't be another Drobo product).

share|improve this answer
up vote 1 down vote accepted

I just got done spending over a month working with Drobo technical support. Apparently there is something strange that happens under certain conditions with Drobo Dashboard (aka DDService.exe) and Windows 7 x64. The basic solution was to not run Drobo Dashboard anymore, which works just fine as the Drobo is only connected to this machine, but overall is a less than satisfactory answer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.