Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wanted to map my PSone gamepad to do some basic KDE/keyboard/mouse functions and everything works well except one thing. I use logitech ultra-x keyboard which has a few multimedia buttons (play, home, volumeup, volumedown..) and I wanted to map volumeup and volumedown keys to my pad with everything else.

volumedown works well, but volumeup makes some trouble. after I start qjoypad and map it - it does work but after mapping it I still see the "[NO KEY]" (while it is doing its job - volumeup; that's strange).. after I turn qjoypad off and on I get this error: "Error reading button 6" and after that "Error reading definition for joystick 0"

this is my layout:

QJoyPad 4.1 Layout File

Joystick 1 {
    Axis 4: gradient, dZone 6505, maxSpeed 11, tCurve 2, sens 2, mouse+h
    Axis 5: gradient, dZone 6264, maxSpeed 11, tCurve 2, mouse+v
    Button 1: key 114
    Button 2: mouse 3
    Button 3: mouse 1
    Button 4: key 113
    Button 5: key 122
    Button 6: key 123
    Button 7: key 62
    Button 8: key 105
    Button 9: key 23
    Button 10: key 65
}

with xev I got it what 122 and 123 are (they work normaly under KDE when I press them, it's just that 123 wont map and stay mapped for my pad)

keycode 122 = XF86AudioLowerVolume
keycode 123 = XF86AudioRaiseVolume

any hint on what I should do to fix this and make my configuration stay? if it means anything, or helps anyhow - system is arch with 2.6.35 kernel, kde 4.5.1 if you need any additional info I can provide it

thank you very much =)

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I was having the same problem, but I found the solution. If you check the source code, it defines the MAXKEY value to be 122 in src/constant.h. Simply change that line to a larger number will do the trick. I have my superkey at 133 and I changed it to 133. Recompile, install and you are OK to go.

Btw, the author might have his reason to cap MAXKEY at 122. Change it at your own risk.

share|improve this answer
add comment

Do you know of anything which causes or leads to the pad buttons not working? Is this over a reboot/login? or during a regular session? is the pad unplugged/replugged? Is there something which you can do that will result in the pad button not working for VolumeUp?

(I went and scanned the qjoypad docs...)

qjoypad docs do show a quirk that occurs when the config window is open with focus, no events will be generated. Is your config window closed?

Is qjoypad changing layouts spuriously? Can you check which layout you're in when it's working, and then again when it's not?

If the keys aren't working after a logout/restart until you start qjoypad, then I'd suggest writing a short script:

#
# start up qjoypad with my 'default' layout
qjoypad "Default"

(or whatever you named it)

And copying/symlinking this into ~/.kde/Autostart (or better, use the System Settings -> Advanced Tab -> Autostart panel to set it up)

This would cause the system to autoload your preferred default layout upon startup. Would that help?

qjoypad looks neat, I'll have to check it out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.