Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to a particular ftp server via WinSCP and the connection always breaks at roughly the same point.

I set the speed to the lowest possible - 1KiB/s

WinSCP reports the transferred bytes as (over multiple tries):

39584
43508
35598
35598
35598

But in most cases the "actual" number of bytes on the drive are 512 or about 1 kB, etc. (Not necessarily a power of 2).

share|improve this question

1 Answer 1

Apart from ensuring that your are using the latest versions of WinSCP and the network card driver, there are two settings of the network card that may cause problems with transfers. Both have to do with offloading tasks from the operating system to the network card, but sometimes the handshake between the two fails.

The problem is that these settings either need to be done on the client or on the FTP server (which I don't know if you control). You can try them one at a time, undoing the ones that don't help.

For lack of information, I'll assume you are on Windows. If you are not, better add to the post your exact operating system and network-card model.

Disable Large Send Offload

  1. Right-click the Network Adapter in Network Connections and then click Properties.
  2. Click the Configure button and then the General or Advanced tab.
  3. Set the "Large Send Offload" parameter to Disable.

Disable Checksum Offloading

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. In the right pane, make sure that the DisableTaskOffload registry entry exists. If this entry does not exist, follow these steps to add the entry:
    1. On the Edit menu, point to New, and then click DWORD Value.
    2. Type DisableTaskOffload, and then press ENTER.
  4. Click DisableTaskOffload.
  5. On the Edit menu, click Modify.
  6. Type 1 in the Value data box, and then press ENTER.
  7. Exit Registry Editor.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.