Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lexmark S305 printer which won't print over wifi however it will happily print a test page.

The printer worked fine before upgrading to Snow Leopard.

I understand the Snow Leopard in built drivers won't allow wifi printing so I have installed the latest Lexmark drivers.

I can access the printer wirelessly by the IP Address.

From the print utility I can cause a test page to be printed.

But if I print anything at all from a regular application it just sits forever in the queue and doesn't even error out.

Does anyone have any clues?

Thanks in advance.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I had the same (really annoying) problem - I found this worked:

http://binnersoft.com/?p=299

this is from the above link:

  1. Uninstall the previous S300 Series software . .Navigate to [Main HD]/Library/Printers/Lexmark/2009/Lexmark S300-S400 Series folder on Finde . .Launch the S300-S400 Series Uninstaller and follow the instructions
  2. Download the S300SeriesWebInstaller_2.0.0. The web package will be auto-mounted.
  3. Double-click Install
  4. Follow the instructions on the computer screen
  5. The installation process ends with the Printer Setup screen of the Lexmark Setup Assistant.

drivers (300SeriesWebInstaller_2.0.0.) found here:

http://downloads.lexmark.com/downloads/cpd/S300SeriesWebInstaller_2.0.0.dmg

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.