Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why is my sent email delayed 30 seconds? Suspect DNS server.

share|improve this question
1  
Could you provide some more context? What version of MacOSX, what MacBook, what wireless router, etc? –  digitxp Sep 26 '10 at 1:20
    
Define what you mean by delayed. It could be a grey-listing issue, it could be batched email processing, it could be a lot of things really. –  MaQleod Sep 26 '10 at 4:27
    
Hi digitxp, Using OS X 10.6.4, 2008 iMac, no wireless router, just a cable modem. I agree could be a grey-listing issue. Will investigate. ISP has checked its settings. Cable guy looked around the house and replaced a splitter resulting in no change in behavior. –  jamescash Oct 1 '10 at 18:07

1 Answer 1

Some email companies use to send emails in batches, so maybe every 5 minutes they send all emails, that were 'sent' in those last 5 minutes, or here 30 seconds. But almost no one does that anymore

gmail was a way to undo send, if the feature is enabled, where it just waits, 3 to 30 seconds, before sending the email. In that time you can hit a cancel button if you realized you've made a mistake.

Whats the domain (@applemail.com or what?), the mail client your using, are you sending the email to yourself, and anything you can tell us about your setup that might be buggered.

share|improve this answer
    
Thanks alpha1, domain is comline.com, using Apple Mail POP, sending to myself and others. Consulted with Apple Genius who deleted a preference file resulting in normal behavior in the Apple Store. Fail back home. The research continues. Current hypothese is fault in our ISP/street network cabling or some 'policy' setting in postfix. –  jamescash Oct 1 '10 at 17:58
    
ok, so then try using a proxy or logging into your email somewhere else, like a library or work, and see if you have the same problem. –  alpha1 Oct 2 '10 at 1:34
    
Thanks alpha1, situation remains unchanged. Discovered no postfix policy setting that would cause slow smtp response. I agree trying other locations can be useful. Meanwhile, I may change DNS settings using OpenDNS and Google's DNS set. Our ISP may have a firewall set. –  jamescash Oct 5 '10 at 6:15
    
Your ISP should have to tell you if they do, so give them a call as ask their policy on it all. –  alpha1 Oct 15 '10 at 2:29
    
We are in contact with our ISP and they are searching for an answer. If a solution is found, I will post. –  jamescash Oct 18 '10 at 16:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.