Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

alt text on Startup

When my system starts up, the internet connection is dead. This causes various problems with startup items such as updates and auto-start programs failing.

However, the connection is fine after going into Network and Sharing, Change adapter settings, then disabling and re-enabling the adapter.

Any suggestions on why this is happening and how to fix it?

System summary: Windows 7, 64 bit, Realtek PCIe GBE Family Controller, Linksys WRT610N router, Sci Atlanta cable modem.

UPDATE: Lately, the network connection for the system mentioned in this question is working about 80% of the time after startup. Have since updated to W7 SP1.

share|improve this question
    
Have you removed and reinstalled the adapter drivers? –  goblinbox Mar 7 '11 at 0:13
    
@goblinbox - Yes –  bill weaver Mar 7 '11 at 19:17
    
If no more suggestions show up and i don't identify the problem in the next few days, i'll probably accept @Jaymz87's or @Scott McClenning's answer. –  bill weaver Mar 10 '11 at 15:04

6 Answers 6

up vote 4 down vote accepted

I had this issue on a friends machine. Seems to be a problem with some Windows 7 installs. The only "fix" I could come up with was to create a batch file with the following:

netsh interface set interface "Local Area Connection" disabled
netsh interface set interface "Local Area Connection" enabled

And have it run on Windows startup. (Replace the "Local Area Connection" with the name of the interface you want to disable/enable)

A little hacky, but it worked.

share|improve this answer

When you boot and the connection is down. I would look to see if any services that were set to startup automatically, but are not currently running. Perhaps some network related service failed (firewall or something). If the service is not running but set to run automatically, try starting the service and see if the network connection works. If so, then you can set in the properties of the service to attempt to restart on failure. (I guess all these failure would be in the system log, that may point you in the right area.)

I had a firewall service that would fail, I set it to restart on failure and then it eventually would work after boot.

share|improve this answer

The way I see it, it works like this:

  1. Boot up windows, it sees "Network" Which is not actually the correct network, but its default imaginary network that it enrolls in, even when there's no cable plugged in.

  2. I power cycle my router (unplug, replug) briefly, just as long as it takes to unplug-replug the power in.

  3. Windows then comes up with "Network 2" as my default network and joins the internet and network.

  4. When I shut down, it immediately forgets that network exists, and defaults back to its imaginary "Network" to again annoy me for no reason at boot-up.

Minding you this is on a fixed cable, with my wireless card disabled completely.

I have no permanent solution, I have to just power cycle my router every single time. Disabling and re-enabling the network doesn't fix it for me.

Hope this helps someone FINALLY find a REAL solution to this. This junk has been happening since day one with Win7.

share|improve this answer
    
I went in and deleted "Network" so that it would hopefully default to Network 2. It did in fact default there, but it still doesn't see the router/network until I power cycle it again. –  Bob Sep 11 '11 at 8:53

Bit old, but for future readers check if you have Id_String1.6844F930_1628_4223_B5CC_5BB94B879762 in your services list. If so, stop it and disable it.

It's the Bonjour service that comes with Adobe CS3 products. Worked for me.

share|improve this answer

I had the same problem when using a Static IP address. I changed my configuration to DHCP and reserved the IP address on the router (effectively making it static). I also set the Alternate configuration so that my "static" address remained if the router was down for any reason.

share|improve this answer

This worked like a charm. Problem SOLVED! No need to anymore disable/enable the Network Adapter.

It seems there's some Apple installed sevice called Bonjour, used with iTunes, or some special features with CS3 (the suite with Dreamweaver, etc.). If you are NOT using Bonjour, get rid of it by doing this:

1) Open File Explorer and Search for Bonjour, very likely in the C: Disk.

2) Locate the folder where Bonjour is. You should have 2 files there: "mDNSResponder.exe" and "mdnsNSP.dll".

3) Go to the Window Start button, look in "Accesories" for the "Command Prompt", the black little box to write things in DOS.

4) Right Click into it, and chose "Run as Administrator", and then click Yes in the next Dialog Box.

5) Do CD (change directory until you are Inside the Bonjour Directory). You should see at the prompt something like "C:\Program Files\Bonjour>".

6) Now type: mDNSResponder.exe -remove

7) You'll get some answer saying it was done OK.

8) Now type: regsvr32 /u mdnsNSP.dll

9) This will unregister the Bonjour DLL. If you do not understand what this means, never mind.

10) Restart your computer, and once it's up, remove completely the Bonjour directory.

11) By now you should see the icon of the Network connection fully up and running, and it'll stay that way every time you start up Windows.

Credit goes to: " http://www.thewindowsclub.com/remove-bonjour-from-windows "

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.