Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot get sound out of the headphone port on a laptop. Headphones are plugged in, and sound comes out of the internal speakers. Windows behaves normally (sound switches to headphones when headphones are inserted).

It did work in Linux at one point, but something changed, we're just not sure what. Rebooting doesn't fix. This appears to occur whether or not PulseAudio is running.

Things I've tried:

  • Rebooting. No effect.
  • Booting into Windows. It works properly, so probably not a hardware issue.
  • All of alsamixer. My only controls are this:

    • "Master" Volume bar & mutable, unmuted. Controls volume.
    • "PCM" Volume bar only. 100%.
    • "S/PDIF" Mutable only, currently muted, has no effect.
    • "S/PDIF" Default PCM", Mutable only, currently unmuted, has no effect.
  • Killing PulseAudio. No effect. (It also won't stay dead! Something appears to be restarting it, and I can't tell what, but it is very annoying.)

  • alsactl init 0, no effect.
  • sudo rm -f /var/lib/alsa/asound.state, no effect.

General system info:

Ubuntu 10.04 LTS Toshiba Satellite T135D-S1324

lspci says I have:

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

Some edits: Yes, the headphones are in all the way.

This works in Windows: You plug headphones in, the internal speakers stop making noise, and noise comes out the head phones. Windows says I only have two sound cards: the HDMI port (which I don't care about) and the "sound card", which it claims is a "Conexant Pebble High Definition SmartAudio" In Windows, both the internal speakers and the headphone jack show up as one soundcard, which in my experience, is typical. (This is a laptop)

share|improve this question
    
Are the headphones in all the way? Sometimes if my headphones are barely out of the jack it will not play the sound. –  Wuffers Oct 8 '10 at 22:41
    
Yes, the headphones are in all the way. :-) –  Thanatos Oct 23 '10 at 5:24

4 Answers 4

if it is about the bug #453395, then the solution is here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/453395/comments/5

share|improve this answer

Your kernel might not be detecting the card properly. Try setting the module options manually by adding the following line to your /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=asus enable_msi=0

(Credit Chris Benninger)

You can find a complete list of options here

You might also want to have a look at the Ubuntu HDA Intel Sound Howto.

share|improve this answer

You might want to see if the the guidance in this thread works:

http://ubuntuforums.org/showthread.php?t=1394553

share|improve this answer

Have you tried installing the pulse audio volume control?

sudo apt-get install paprefs pavucontrol pavumeter

Also, In the "sound preferences" dialogue (click the speaker icon on the tray) does the hardware tab show your sound card? Do you see the device you're trying to use on the output tab? You may have to change the 'profile' setting to use the headphones instead of the speakers.

share|improve this answer
    
Thanks for the response to an old question (this is still as issue...). paprefs doesn't show anything useful, and pavucontrol doesn't seem to have any settings for switching between the speakers and the headphones. My understanding is that they show up as one soundcard, not as two. (I have another laptop, a Thinkpad, that does this.) –  Thanatos Jan 30 '11 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.