Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Toshiba A665-S6065 which I bought about 1.5 months ago. It's been working perfectly with windows 7 (64 bit) and ubuntu (64 bit) dual booting.

However, a few days ago I noticed that only 1940 mb of ram were being used by linux. I know this definitely was not the case several weeks ago.

I tried rebooting into windows 7 to see if it was a problem with linux, but again, only half my ram was actually being used by windows. Looking at the bios settings page, it says that the computer has 4gb of ram. I ran memtest86, and all 4gb were recognized and no errors were found.

I have no idea what's causing this problem, and if I can't fix it, I'm going to just return it for another laptop.

share|improve this question
Does Windows still show the full 4GBs of RAM in system information? (Press WinKey+Pause/Break). It could still see all 4GB but is using the swap file more aggressively for some reason. – TuxRug Sep 27 '10 at 0:05

First step: power down your machine, remove the memory modules and reinsert them.

Check your owner's manual for details - the memory modules are typically accessible through a small cover on the underside of the laptop, secured by a couple of small screws.

If the memory jumps back to 4GB when you power up the laptop, it means one of the modules became unseated. You should now be good to go.

If you still see 2GB, try booting with only one module installed at a time. I would expect the laptop to boot fine with one module and fail to boot with the other, indicating that one module has died. If you fail to boot with one module, you should try that module once in each of the two memory sockets, to make sure the issue is the module and not the socket.

After following those steps, you should know which module or socket is bad. Then the question is whether they are under warranty. If not, I would buy either a new 4GB kit or a single 2GB module of the same specs (ideally the same brand and model) to replace the bad one.

Happy troubleshooting!

share|improve this answer

However, a few days ago I noticed that only 1940 mb of ram were being used by linux.

What do you mean by this statement? That the OS recognizes only 2GB ram or that it recognizes 4GB but uses only 2GB? In that case its perfectly okay as that would be dependent on the applications in use

share|improve this answer
Output of free -m only shows 1940mb of total ram. Windows 7's task manager also shows only 1940mb total ram. – pklall Sep 27 '10 at 1:20

You must log in to answer this question.