Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Unibody Macbook Pro with the latest version of Snow Leopard. I often use the laptop with an external mouse, monitor, and keyboard. I have had this configuration for a few years and only in the recent months have had a mouse issue.

The mouse seems to "half" work in that navigation and clicking works. But things that rely on hovering do not. So expose, highlighting menu items, etc don't work. For example if I click the Apple logo (top left) and then hover over About This Mac, the menu item will not be highlighted.

I've tried plugging in the USB devices in multiple configurations but nothing seems to cure it forever. It comes and goes. To add to the frustration, if I open the laptop and use the trackpad, the same symtoms will occur but as soon as I unplug the USB port, the track pad (and cursor) begin functioning normally!

Help!

share|improve this question
    
got another mouse to try? –  Yar Sep 26 '10 at 22:43
1  
Sounds like this is a software issue to me... –  TM. Sep 26 '10 at 22:56
    
Try with another keyboard and mouse - perhaps something is sticking on - sounds like hardware as with no USB addons it works –  Mark Sep 26 '10 at 23:47
    
Yeah I actually switched and tried it with a Magic Mouse. So now that's over bluetooth and it still does this until I unplug the USB mouse. So maybe that mouse is suspect? I just ordered a Magic Trackpad and we'll see if that fixes anything when used exclusively. I think its a bug in OSX. –  Ternary Sep 27 '10 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.