Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed rails and am working my way through the tutorial on railstutorial.org. In CH2 where you set up the basic app, after I generate the scaffold for the users and I try to load the page, @http@://localhost:3000/users I receive:

LoadError: (no such file to load -- openssl):

The default page loads properly. I even tried the tutorial on http://guides.rubyonrails.org and changed the config/routes.rb file to read:

  Blog::Application.routes.draw do    
  #...  # You can have the root of your site routed with "root"  
  # just remember to delete          public/index.html.  
  root :to => "home#index" 

The error is still the same. I am not sure what openssl is.

Any help is appreciated. Many thanks.

Edit: Sorry. Using Fedora 13 and Ruby1.9.2/Rails 3.0

share|improve this question
    
Which OS are you using ? Also mention the version of Ruby & Rails –  Sathya Sep 27 '10 at 4:10

2 Answers 2

up vote 0 down vote accepted

Try using RVM, you can manage ruby versions and gems easily. It also provides answers for many questions related to missing libraries like openssl in your case. link text

share|improve this answer
    
That did it. Thank you kindly. –  winarm Nov 16 '10 at 19:12

My guess is that Ruby was built without OpenSSL support. Try building from source, following step 4 of the readme: edit ext/Setup and remove the # before openssl. Then make and make install.

Note: I don't have a Fedora system available, so I haven't tested this.

share|improve this answer
    
Changed the file as instructed and ran make-make install. Same result. I probably messed up something. Thanks though –  winarm Sep 28 '10 at 17:37
    
If you don't have the ssl headers, it won't build. Did you get any output along those lines when you ran make? –  Velociraptors Sep 28 '10 at 22:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.