Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a linux noob and am trying to install ORacle10g on RHEL5 but am running into difficulties on the requirements stage. The only 2 packages I require is gnome-libs and xscreensaver.

I have downloaded both:
'gnome-libs-1.4.1.2.90-44.1.i386.rpm
'xscreensaver-4.18-5.rhel4.11.i386.rpm'

But when I try to install them I get dependency errors. I have been trawling sites and forums for 2 days now and am no closer to resolving this and continuing with my Oracle install.

To pre-empt possible trouble-shooting questions, here is a list of the dependcies that could not be resolved:

For gnome-libs:
libdb.so.2(GLIBC_2.0)
ORBit
libdb.so.2
libllOP.so.0
libORBitCosNaming.so.0
libORBitutil.so.0
libORBit.so.0
libpng.so.2
And it says all the above is needed by package 1:gnome-libs-1.4.1.2.90-44.1.i386(/gnome-libs-1.4.1.2.90-44.1.i386)

For xscreensaver:
xloadimage is needed by package 1:xscreensaver-4.18-5.rhel4.11.i386(/xscreensaver-4.18-5.rhel4.11.i386)

Sorry if I have explained this in a crap way - like I said - linux noob here. Any help with this would be great, its been a long 2 days so far - i need to get this resolved soon.

Thanks

share|improve this question
    
Where did you download Oracle 10g from ? And what edition is this ? – Sathya Sep 27 '10 at 13:34
up vote 0 down vote accepted

Install libgnome, libgnomeui and libXp with yum install libgnome libgnomeui libXp

That should be what you need.

share|improve this answer

Stop trying to install RHEL 4 packages on a RHEL 5 system. Use yum to install the libraries you need instead.

share|improve this answer
    
I have tried using yum but with no success. Due to my inexperience I might be using it wrong - any chance of a quick example of the commands to use to install these 2 packages via yum? I have already tried but just in case I am doing it wrong. Thanks – Frank Sep 27 '10 at 9:49
    
The reason you can't install these packages via yum because they don't exist in RHEL 5 in the first place. You need to back up and figure out what you really need. – Ignacio Vazquez-Abrams Sep 27 '10 at 9:56
    
OK but I cant seem to find a RHEL5 version of either - I have downloaded the most recent versions i could find. – Frank Sep 27 '10 at 9:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .