Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've owned a DIY-built PC on a Gigabyte GA-EP35C-DS3R motherboard for about 2 years now. When I first built this PC, it ran perfectly under Windows XP 32-bit. Performance was good, and I had no issues with freezeups or audio distortion. I recently upgraded to Windows 7 64-bit, and since then, I've had serious performance problems. The system occasionally freezes up, usually for only a second but sometimes for more than 15 seconds. I get distortion in audio playback through the onboard Realtek Azalia HD-Audio, which sounds like the audio is frozen on a single tone for half a second or more, turning it into a buzzing sound. Video playback stops and stutters every few seconds as well. Disk and network performance are also significantly worse than under Windows XP. I get 2D graphics slowdowns drawing simple windows, like something out of 1995.

I've done research on my issues and found that they seem to relate to problems with driver DPC latency and hard pagefaults. I've been using the DPC Latency checker from www.thesycon.de/deu/latency_check.shtml, and I see frequent spikes of latency over 4ms. Baseline latency is rarely lower than 0.5ms, and is usually around 1ms idle, closer to 2ms when working. I've also used the Latency Monitor tool at www.resplendence.com/latmon , and it's reported hard pagefaults longer than 500ms, and DPC latency of over 2.3ms in netbt.sys.

I've tried disabling EIST and C1E in BIOS, and this helped a little bit. Disabling the onboard ethernet, sound, or USB also helps, but this is unacceptable, as I require all of these functions.

Before anyone asks, I've spent weeks ruling out other possible causes. I've malware and spyware scanned with four separate programs. I've chkdsked, defragged, cleared temp files, rebuilt page files, and swept my registry for errors with two different programs. I've disconnected every piece of hardware I could, checked every internal connection, checked my memory for errors with Memtest86+ for a whole weekend while I was out of town, run CPU burnin programs, swapped most of the cables, and even moved my RAID from the Intel Matrix controller to the GBB36X controller. I have a copy of Fedora 13 (GNU/Linux) on another boot drive which runs perfectly and extremely fast on this hardware. There's something about the way Windows 7 interacts with this motherboard.

I've seen that other similar Gigabyte P35 motherboards have had this issue, and some have been helped by BIOS updates.

forum.cakewalk.com/tm.aspx?m=1351472&mpage=1&key="

forums.tweaktown.com/gigabyte/26456-p35-motherboards-dpc-latency-spiking-19.html

forum.cockos.com/showthread.php?t=20413

I have the latest BIOS for my motherboard, which does not appear to have had an update from Gigabyte regarding this issue. I've filed a ticket with them in hopes that they can help.

Does anyone have any suggestions to how I might recover? I really don't want to roll back to Windows XP!

share|improve this question
    
For a description of (a) what's wrong and (b) what you have already tried I don't think I've seen better! What a lot of time you have invested, but glad you had a good result. –  pnuts Dec 1 '12 at 9:01
1  
It's been quite stable for a long time now. I think that the most confusing thing I had to overcome was that Intel renamed their drivers from "Matrix Storage Technology" to "Rapid Storage Technology" during the lifetime of the ICH9R chipset that this motherboard uses. I was trying to install Matrix drivers that didn't support Win7x64, and only later stumbled on the RST drivers that I actually did need. –  Ryan M Jan 7 '13 at 20:59
add comment

3 Answers

up vote 0 down vote accepted

Have you tried turning off all raid & ahci stuff in bios and disable NIC too just to be sure, then install fresh 7 onto a hdd that's in "legacy SATA" mode. I don't recall having as bad issue but I definitely had similar freeze&audio issues when the onboard raid/ahci was in use.

share|improve this answer
    
I solved this by reinstalling Windows 7 and having the latest Intel Rapid Storage Tech drivers ready to load during the install process. Pain in the neck, but now it's nice and fast. –  Ryan M Nov 7 '10 at 14:06
add comment

I solved this issue by disabling the SNMP function in Win7.

I think this feature is turned off by default, but is required for Gigabyte hardware monitoring, hence enabled as suggested by the Gigabyte software (G.O.M.).

To turn it off: Control Panel - Programs - Turn Windows Features On or Off - deselect Simple Network Management Protocol. The only disadvantage is that you can't use G.O.M. anymore, no big deal for me.

share|improve this answer
add comment

on a gigabyte P35 board, disable EIST in bios and it should help reduce the problem. Also update your drivers.

share|improve this answer
    
OP already states "I've tried disabling EIST and C1E in BIOS" and has accepted an answer to which he has commented "having the latest Intel Rapid Storage Tech drivers" so -1 I'm afraid as I don't see your answer adds anything. –  pnuts Dec 1 '12 at 8:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.